Blank rows in thread pane in this case (del from msg win, then Go)

VERIFIED FIXED in mozilla0.9.2

Status

SeaMonkey
MailNews: Message Display
VERIFIED FIXED
17 years ago
13 years ago

People

(Reporter: laurel, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
mozilla0.9.2

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Using may08 commercial trunk build

Found this case where we display bogus/empty rows in the thread pane...

1.  Logged into IMAP account, in mail window.
2.  Select a folder, select a message (I chose midway down the thread pane list)
and open it to a standalone message window.
3.  From the standalone window click Delete button, repeat to delete a couple
messages.  
4.  Close the standalone window. You're placed back in the main mail window
without any selection in the thread pane.
5.  Go|Previous|Message.  Repeat.  Notice there are now a couple empty rows at
the top of the thread pane.

Result:  blank rows added to top of the thread pane.
(Reporter)

Updated

17 years ago
QA Contact: esther → laurel

Comment 1

17 years ago
are you seeing this in the 5/9 build.  I can't reproduce this on Win 2000 using
2001050904
good catch, I can reproduce this.
Status: NEW → ASSIGNED
simpler way to reproduce:

open a folder with a lot of messages, before you select one, scroll to the 
middle.

hit "b" (for go | previous | message)

working on a fix now.

a spin off of laurels original bug is:  "when we the current selected message 
gets deleted from under us, we need to blank the thread pane."  I'll log that 
after I fix this bug.
Target Milestone: --- → mozilla0.9.2
another bug "when there is no selection, certain navigation should be 
disabled.  next message, previous message, etc.  not all should be disabled.  
for example, next unread should be enabled."

I'll log both bugs once I've fixed this.
Created attachment 34276 [details] [diff] [review]
fix
fixed.

now I'll go log those other bugs.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
logged bugs:

http://bugzilla.mozilla.org/show_bug.cgi?id=80545
http://bugzilla.mozilla.org/show_bug.cgi?id=80546
(Reporter)

Comment 8

17 years ago
OK using may14 commercial trunk build: linux rh6.2,win98, mac OS 9.0
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.