Closed Bug 795889 Opened 9 years ago Closed 9 years ago

Nightly crashes on startup a day after installing Facebook sidebar

Categories

(Firefox Graveyard :: SocialAPI, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 795728

People

(Reporter: osmose, Unassigned)

Details

About a day after installing the Facebook sidebar my profile on Nightly has started to crash on startup. I was able to get the profile running on a release copy of Firefox, and I disabled social.active and social.enabled in about:config, but the profile still crashes on startup in Nightly.

Let me know if there's a way to get detailed crash info I can post to the bug. My install worked fine up until installing now, and I haven't installed anything else since the sidebar, so I doubt it is an unrelated issue.
I am able to reproduce this, I'll search for the apropriate bug (assuming there already is a crash bug), but here are some details

console:

2012-10-01 10:18:37.357 firefox-bin[86127:507] invalid drawable
pure virtual method called

apple crash reporter:

Process:         firefox-bin [86127]
Path:            /Applications/FirefoxNightly.app/Contents/MacOS/firefox-bin
Identifier:      org.mozilla.nightly
Version:         18.0a1 (1812.10.1)
Code Type:       X86-64 (Native)
Parent Process:  bash [370]

Date/Time:       2012-10-01 10:18:45.054 -0700
OS Version:      Mac OS X 10.7.4 (11E53)
Report Version:  9

Interval Since Last Report:          4853229 sec
Crashes Since Last Report:           65
Per-App Interval Since Last Report:  63 sec
Per-App Crashes Since Last Report:   1
Anonymous UUID:                      37BE1717-F920-48B2-985E-CC5400673E32

Crashed Thread:  0  Dispatch queue: com.apple.main-thread

Exception Type:  EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000

Application Specific Information:
objc[86127]: garbage collection is OFF
pure virtual method called
abort() called

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   libsystem_kernel.dylib        	0x00007fff980e5ce2 __pthread_kill + 10
1   libsystem_c.dylib             	0x00007fff94b867d2 pthread_kill + 95
2   libsystem_c.dylib             	0x00007fff94b77a7a abort + 143
3   libc++abi.dylib               	0x00007fff91d4b7bc abort_message + 214
4   libc++abi.dylib               	0x00007fff91d4909c __cxa_pure_virtual + 18
5   XUL                           	0x000000010202321c mozilla::layers::ContainerLayer::DefaultComputeEffectiveTransforms(gfx3DMatrix const&) + 1436
6   XUL                           	0x000000010202321c mozilla::layers::ContainerLayer::DefaultComputeEffectiveTransforms(gfx3DMatrix const&) + 1436
7   XUL                           	0x00000001020346a9 mozilla::layers::LayerManagerOGL::EndTransaction(void (*)(mozilla::layers::ThebesLayer*, gfxContext*, nsIntRegion const&, nsIntRegion const&, void*), void*, mozilla::layers::LayerManager::EndTransactionFlags) + 89
8   XUL                           	0x00000001011dca22 nsDisplayList::PaintForFrame(nsDisplayListBuilder*, nsRenderingContext*, nsIFrame*, unsigned int) const + 1506
9   XUL                           	0x00000001011dc422 nsDisplayList::PaintRoot(nsDisplayListBuilder*, nsRenderingContext*, unsigned int) const + 178
10  XUL                           	0x00000001011fafac nsLayoutUtils::PaintFrame(nsRenderingContext*, nsIFrame*, nsRegion const&, unsigned int, unsigned int) + 2812
11  XUL                           	0x00000001012157e2 PresShell::Paint(nsIView*, nsRegion const&, nsIPresShell::PaintType, bool) + 658
12  XUL                           	0x000000010166d2f0 nsViewManager::ProcessPendingUpdatesForView(nsView*, bool) + 416
13  XUL                           	0x000000010166ec8a nsViewManager::ProcessPendingUpdates() + 282
14  XUL                           	0x000000010121d1dd nsRefreshDriver::Notify(nsITimer*) + 2445
15  XUL                           	0x0000000101f98b90 nsTimerImpl::Fire() + 400
16  XUL                           	0x0000000101f98cc2 nsTimerEvent::Run() + 34
17  XUL                           	0x0000000101f9574d nsThread::ProcessNextEvent(bool, bool*) + 653
18  XUL                           	0x0000000101f5622e NS_ProcessPendingEvents_P(nsIThread*, unsigned int) + 78
19  XUL                           	0x0000000101d2ec57 nsBaseAppShell::NativeEventCallback() + 103
20  XUL                           	0x0000000101ce9700 nsAppShell::ProcessGeckoEvents(void*) + 304
21  com.apple.CoreFoundation      	0x00007fff8fe414f1 __CFRUNLOOP_IS_CALLING_OUT_TO_A_SOURCE0_PERFORM_FUNCTION__ + 17
22  com.apple.CoreFoundation      	0x00007fff8fe40d5d __CFRunLoopDoSources0 + 253
23  com.apple.CoreFoundation      	0x00007fff8fe67b49 __CFRunLoopRun + 905
24  com.apple.CoreFoundation      	0x00007fff8fe67486 CFRunLoopRunSpecific + 230
25  com.apple.HIToolbox           	0x00007fff8faf94d3 RunCurrentEventLoopInMode + 277
26  com.apple.HIToolbox           	0x00007fff8fb00781 ReceiveNextEventCommon + 355
27  com.apple.HIToolbox           	0x00007fff8fb0060e BlockUntilNextEventMatchingListInMode + 62
28  com.apple.AppKit              	0x00007fff9232fe31 _DPSNextEvent + 659
29  com.apple.AppKit              	0x00007fff9232f735 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 135
30  XUL                           	0x0000000101ce8d56 -[GeckoNSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 86
31  com.apple.AppKit              	0x00007fff9232c071 -[NSApplication run] + 470
32  XUL                           	0x0000000101ce9e96 nsAppShell::Run() + 54
33  XUL                           	0x0000000101b74599 nsAppStartup::Run() + 41
34  XUL                           	0x000000010100968c XREMain::XRE_mainRun() + 2940
35  XUL                           	0x00000001010098d3 XREMain::XRE_main(int, char**, nsXREAppData const*) + 451
36  XUL                           	0x0000000101009bb0 XRE_main + 208
37  firefox-bin                   	0x0000000100001f40 main + 1184
38  firefox-bin                   	0x00000001000017c4 start + 52
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 795728
What is the 'facebook sidebar' mentioned in the original comment? 

I can't reproduce this with this addons: https://addons.mozilla.org/en-US/firefox/addon/facebook-toolbar/
I believe the "Facebook Sidebar" in this case refers to the Social API sidebar with Facebook whitelisted.
(our work with Facebook has not yet been announced, hence why this bug is marked mozilla-confidential)
Group: mozilla-corporation-confidential
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.