Outgoing SMTP default server ignored.

RESOLVED DUPLICATE of bug 649182

Status

RESOLVED DUPLICATE of bug 649182
6 years ago
6 years ago

People

(Reporter: PBo35, Unassigned)

Tracking

15 Branch
x86_64
Windows Vista

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.0; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0.1
Build ID: 20120905151427

Steps to reproduce:

1. when creating a new mail
2. when answering a mail which you received in an account that has been deleted


Actual results:

Default SMTP server is ignored
1. the SMTP of the first account is used
2. the SMTP of the (last? at least for me it's the last one) account is used


Expected results:

the default SMTP server and associated account should have been used

This appears like an old bug (2005-2006). Was it resolved then? However, today, mine shows this broken behavior.
It's really annoying to have to change the sending account on every mail written.
(Reporter)

Comment 1

6 years ago
It's been like that for a while, at least several months, maybe a year.

Comment 2

6 years ago
What do you mean by the account being deleted?
(Reporter)

Comment 3

6 years ago
I mean you have a mail account smith@yahoo.com

you use it for a couple of years

then one day, because this address receives too much spam, you go to tools, accounts (sorry my thunderbird is in French so I can't give you the exact terms of the menu), you select smith@yahoo.com, and in the menu at the bottom left of the window you select "delete account". I don't know any other way of deleting an account.
(Reporter)

Comment 4

6 years ago
seems same as Bug 649182
I seem to have solved my problem by selecting "default account" instead of selecting "default SMTP server".
The latter option still seems to be ineffective, I have no idea what "default" under "outgoing SMTP server" is supposed to do.
Isn't it redondant? Isn't it better to remove the default SMTP server which leads to error, and I've seen that I'm not the only one (Bug 649182)?

Comment 5

6 years ago
Those 2 functions are not redundant, they are different.
There is not a "SMTP server and its associated account".
It is "an account and its associated SMTP server". So if you want to choose which account/identity address is shown in the Reply/Compose window in the From field then you want to set the Default account. That account has a setting (on Server settings pane) through which SMTP server that email will be sent out.

Yes there is also the function of Default SMTP server. That is used when you switch networks often (or other reasons). You set several accounts to use the "default outgoing SMTP server". Then, when needed you go into the SMTP panel and change which SMTP server is the default. This way you change how all those accounts will send out email. But that does not change the email address stored in those accounts that will appear in the From field on compose window. That one is a property of each account.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 649182
(Reporter)

Comment 6

6 years ago
Thank you aceman for your explanations which make it quite clear.
I've associated an account with only one SMTP server and vice versa, which made it difficult to see the point, because smtp servers I know only accept sends from their own accounts: eg. yahoo smtp won't send a mail from my gmx account and vice versa and it's true for all ISPs'email accounts I know of here.
You need to log in before you can comment on or make changes to this bug.