Status

defect
RESOLVED DUPLICATE of bug 797627
7 years ago
a year ago

People

(Reporter: BenWa, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [b2g])

Reporter

Description

7 years ago
With bug 792855 we'll be able to debug/profile a single process remotely (Fennec). The goal of this bug is to extend this to support profiling a multi-process system such as B2G.

The current design is to have a central debugging server living in the control process. When child processes are spawned they will register to the central debugging server. When a client wants to connect it will initiate the connect with the central server which will multiplex and proxy the messages to the correct child process (content, plugin).

With this approach we only need to deal with a single external RDP server.
Moving to the debugger component since this is a core change and will be necessary for debugging B2G as well.
Component: Gecko Profiler → Developer Tools: Debugger
Product: Core → Firefox
Whiteboard: [b2g]
Reporter

Updated

7 years ago
No longer blocks: 758697
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 797627

Updated

a year ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.