[Dialer App] Don't enable screen timeout when connected to a call

VERIFIED FIXED

Status

Firefox OS
Gaia
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: tchung, Assigned: etienne)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Reporter)

Description

5 years ago
Crossposting from https://github.com/mozilla-b2g/gaia/issues/5427.  It was blocking-basecamp+'d in github.

If im on a call that exceeds the screen timeout period, the screen timing out causes all sorts of inconveniences to get back to.   In particular, hanging up the call, wanting to enter the keypad, interacting with the dialer app...
The problem is to get back to the screen after timing out, the user needs to execute the following steps:
1. click power to wake up screen
2. do the lock slider thingy
3. enter in Passcode (if enabled)
4. homescreen launches, go find the dialer app
5. Click the dialer app.   Finally, you're back into the state where you were before the timeout.

This is particularly annoying if i just wanted to hang up the call or if the call was disconnected on the other end.  Doing 5 steps is clumsy, especially if i need to make a time sensitive action like enter in some keys on the keypad in a connected call.

## Environment :
* Otoro daily: 9-28-2012
* gaia commit: dbe752c2bc61835a92469cb0e35ad5d938a754d5
* gecko commit: 5e9ba780a2f3db83364a87a7b976eafe4ae834b2


## Repro :
1. Launch dialer, and make a call
2. stay connected to the call until the default screen timeout occurs
3. once the screen goes black, wake it up again by following the steps mentioned above
4. Verify its too long to do all those steps just to get back into the call.

## Expected :
* I suggest as long as the user is connected to a call, we keep the screen awake.  that way they can quickly access the dialer app controls when needed without having to wake it up again.  I think Iphone does this.

## Actual :
* Screen times out on a long connected call.
(Assignee)

Updated

5 years ago
Assignee: nobody → etienne
(Reporter)

Updated

5 years ago
Duplicate of this bug: 796041
Etienne, should we mark this bug as fixed, it already landed in gaia:

https://github.com/mozilla-b2g/gaia/commit/3e360f0875e519743e2ce3159cbb035d5e8334e1
(Assignee)

Comment 4

5 years ago
Yes, my bad.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 5

5 years ago
Otoro daily: 10-10-2012
* gaia: 2667536e3b06e46dd193aa6d76ba08dad2d867be
* gonk: 6ec34aa3d66331054de37eabc594ad923654b27c

Set screen timeout to 1, 2, 5 minutes and made a call for each scenario.  Screen stayed alive during my calls (although it dimmed if there was no touch action and dimmer was set to "adjust automatically").
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.