Printer Properties causes Firefox to crash in dlbcui5c.dll print driver

RESOLVED INVALID

Status

()

Toolkit
Printing
--
critical
RESOLVED INVALID
5 years ago
2 years ago

People

(Reporter: sally, Unassigned)

Tracking

({crash})

15 Branch
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 666612 [details]
firefox 15.0.1 image one.JPG

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:15.0) Gecko/20100101 Firefox/15.0.1
Build ID: 20120905151427

Steps to reproduce:

i have windows xp home sp3
dell 720 printer
no update drivers for this printer



Actual results:

ever since i upgraded to firefox 15.0 my firefox crashes when i try to access the printer properties from the firefox browser and continues to do so even when firefox upgraded too 15.0.1.

i believe this is a firefox bug, it never did this until the firefox version series 15.0 and up.

i can access the printer properties from the control panel on my pc just fine, just not when i try to get to the printer properties from firefox.

i can access my printer properties from the newest version of GOOGLE CHROME and from IE 8 with no problems.

please fix this 


Expected results:

hope this link can help, its a crash report of my browser 15.0.1.

https://crash-stats.mozilla.com/report/index/bp-2391ec67-34d4-4e97-b44e-805742121001

Comment 1

5 years ago
Firefox crashes in dlbcui5c.dll which belongs to the Dell Photo Printer driver.
It's not a bug in Firefox.
Please update your printer driver and report back.
Severity: normal → critical
Crash Signature: [@ @0x0 | dlbcui5c.dll@0x6fc1]
Keywords: crash
(Reporter)

Comment 2

5 years ago
this printer is so old, like december 2005, and i looked on the dell site and i have the latest driver , so its still a firefox bug, cuz when i had an older version of firefox , it worked just fine . no problems . please fix firefox.

google chrome and IE lets me do it , so its firefox

Comment 3

5 years ago
So it means the latest version of Firefox highlights an underlying printer driver bug.
Component: Untriaged → Printing
Product: Firefox → Toolkit

Comment 4

2 years ago
(In reply to sally from comment #2)
> this printer is so old, like december 2005, and i looked on the dell site
> and i have the latest driver , so its still a firefox bug, cuz when i had an
> older version of firefox , it worked just fine . no problems . please fix
> firefox.
> 
> google chrome and IE lets me do it , so its firefox

Even so, it is crashing in the driver dlbcui5c.dll, not firefox. Even if a workaround could be created in firefox, it's unlikely given the age of the printer - unless other printers are affected.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
Summary: date 10-1-12) Printer Properties causes Firefox to crash → Printer Properties causes Firefox to crash in dlbcui5c.dll print driver
You need to log in before you can comment on or make changes to this bug.