Cannot drag a bookmark with no name

VERIFIED FIXED in mozilla0.9.3

Status

--
minor
VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: JesseK, Assigned: bugzilla)

Tracking

Trunk
mozilla0.9.3

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fix in hand, URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9) Gecko/20010505
BuildID:    20010505

With the bookmark manager it seems impossible to drag a bookmark that does not
have a name.  Renaming the bookmark to something fixes this and allows you to
drag the bookmark once more.

Reproducible: Always
Steps to Reproduce:
1. Add a bookmark
2. Go to Bookmark properties and blank out the name field (imported bookmarks
from Netscape are sometimes imported with blank name fields)
3. Go into the Bookmark Manager - and attempt to drag the bookmark.

Actual Results:  You will be unable to drag the bookmark at all.

Expected Results:  You should be able to drag the bookmark regardless of name.

When I imported my existing Netscape bookmarks into Mozilla - several of them
had no names.  I do notice that with Mozilla, bookmarking a page with no name
gives it a default name of the url - so this bug is only reproducable from
direct editing of the bookmark names or through importing of existing bookmarks.

Comment 1

18 years ago
*** Bug 84105 has been marked as a duplicate of this bug. ***

Comment 2

18 years ago
confirmed on all platforms with 2001060503 branch builds but im guessing since it's
old it's on the trunk too
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Hardware: PC → All

Comment 3

18 years ago
Also confirmed for me, build 2001-06-09-20, Win2k sp2

Marking my vote, if I have enough!  :)

Comment 4

18 years ago
Need to mention also:

Cut/Paste bookmark does work (and is thus a good workaround).
(Assignee)

Comment 5

18 years ago
--> me
Assignee: ben → blake
(Assignee)

Comment 6

18 years ago
Created attachment 39945 [details] [diff] [review]
patch
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Whiteboard: fix in hand
Target Milestone: --- → mozilla0.9.3

Comment 8

18 years ago
r=timeless

Comment 9

18 years ago
WFM on 2001071803 on Win2k.
(Assignee)

Comment 10

18 years ago
oh yeah, I checked this in.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
mass-verifying claudius' Fixed bugs which haven't changed since 2001.12.31.

if you think this particular bug is not fixed, please make sure of the following
before reopening:

a. retest with a *recent* trunk build.
b. query bugzilla to see if there's an existing, open bug (new, reopened,
assigned) that covers your issue.
c. if this does need to be reopened, make sure there are specific steps to
reproduce (unless already provided and up-to-date).

thanks!

[set your search string in mail to "AmbassadorKoshNaranek" to filter out these
messages.]
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.