[Camera App] Taking a picture will slightly shrink the image before saving

RESOLVED DUPLICATE of bug 866790

Status

Firefox OS
Gaia::Camera
P3
normal
RESOLVED DUPLICATE of bug 866790
6 years ago
5 years ago

People

(Reporter: GH to BZ, Unassigned)

Tracking

({polish})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [label:camera])

(Reporter)

Description

6 years ago
[GitHub issue by tonychung on 2012-09-12T01:18:39Z, https://github.com/mozilla-b2g/gaia/issues/4596]
When taking a picture with Camera app, notice that right before the image is saved, the image gets slightly shrunk.

## Environment :
* Otoro daily: 9-11-2012
* gaia commit: 6cb41daf1073643c86d74624dd8cf55950171e3d
* gecko commit: 105845cdabbd043b9975a6937ebd84e3ff4cdca3


## Repro :
1. launch Camera App
2. take a picture of something
3. Watch as the original image you see in the preview, shrink slightly on both sides when the image is captured and saved.

## Expected :
* picture is taken in the same dimensions that the camera preview shows

## Actual :
* picture slightly shrinks once the image is taken on the left and right sides
(Reporter)

Comment 1

6 years ago
[GitHub comment by daleharvey on 2012-09-26T02:37:36Z]
Just making a note that this is likely due to a difference due to the aspect ratio of the final photo and the preview, will force the preview aspect ratio and see if that helps

pinging @mikeaich in case you have any other ideas
(Reporter)

Comment 2

6 years ago
[GitHub comment by mikeaich on 2012-09-26T13:48:39Z]
@daleharvey if you can sort this out in gaia, that would be great.  If not, let me know and I'll dig into the platform.  I agree with your assessment of the likely cause.
Duplicate of this bug: 796296

Updated

6 years ago
Component: Gaia → Gaia::Camera

Comment 4

6 years ago
duplicate 808672

Updated

6 years ago
Keywords: polish
Priority: -- → P3
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 866790
You need to log in before you can comment on or make changes to this bug.