[settings] Camera app fails to launch after using it to set the wallpaper in settings.

RESOLVED DUPLICATE of bug 796293

Status

P1
normal
RESOLVED DUPLICATE of bug 796293
6 years ago
6 years ago

People

(Reporter: ghtobz, Assigned: daleharvey)

Tracking

unspecified

Firefox Tracking Flags

(blocking-basecamp:-)

Details

(Whiteboard: [label:camera][label:settings])

(Reporter)

Description

6 years ago
[GitHub issue by nhirata on 2012-10-01T16:40:48Z, https://github.com/mozilla-b2g/gaia/issues/5586]

## Environment :
Otoro phone, build 2012-10-01 us
Taken from default.xml in b2g-distro: 
* "platform_build" revision= 795261940c8b11fb7dddd7a8e9dd8561fdc4fb64
* "gaia" revision= 5feb07b511ab907942731fc4961ccbce3958d021 
* "releases-mozilla-central" revision= 80b40bba7f30f6cea5cb148cbbdcbf008691972b
* "gonk-misc" revision= 202d2c62443c098b125e5d9d7b42226d98230e44
  
## Repro :
1. go to settings -> display
2. select wallpaper picture
3. select camera

## Expected :
1. camera app launches, you can take a picture and set as wallpaper

## Actual :
1. camera app tries to launch, goes black, lockscreen appears and you are back in homescreen after unlocking.

## Note :
* logcat : https://gist.github.com/3812907
* in my opinion, we need to get either rid of the camera option or make it work
(Reporter)

Comment 1

6 years ago
[GitHub comment by daleharvey on 2012-10-01T16:46:53Z]
Thats a strange note, of course if features dont work we will fix them
blocking-basecamp: ? → +
Priority: -- → P1
(Assignee)

Comment 2

6 years ago
I/Gecko   (  106): [Parent 106] WARNING: pipe error (177): Connection reset by peer: file /Volumes/Boot2Gecko/B2G/gecko/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 421
I/Gecko   (  106): [Parent 106] WARNING: waitpid failed pid:725 errno:10: file /Volumes/Boot2Gecko/B2G/gecko/ipc/chromium/src/base/process_util_posix.cc, line 260
I/Gecko   (  106): [Parent 106] WARNING: waitpid failed pid:725 errno:10: file /Volumes/Boot2Gecko/B2G/gecko/ipc/chromium/src/base/process_util_posix.cc, line 260
I/Gecko   (  106): [Parent 106] WARNING: Failed to deliver SIGKILL to 725!(3).: file /Volumes/Boot2Gecko/B2G/gecko/ipc/chromium/src/chrome/common/process_watcher_posix_sigchld.cc, line 118

is the crash
That's just the parent process noticing that the child has crashed.

I believe this is the same bug that Gene and Fabrice are working on, but I don't remember the other bug number.
(Assignee)

Comment 4

6 years ago
It is the exact bug, closing as dupe
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 796293
blocking-basecamp: + → -
You need to log in before you can comment on or make changes to this bug.