Image does not render when /-/ is in source

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
18 years ago
4 years ago

People

(Reporter: maxp, Assigned: pavlov)

Tracking

({dataloss, regression})

Trunk
mozilla0.9.7
dataloss, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [imglib], URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
The images used with various <img height=... > attributes to 
implement kinda "bar graph".

But those images are't visible in Mozilla-0.9 screen.
It is ok with other browsers and with mozilla 0.8.1

http://www.ozero.net/~maxp/mozilla-bug.jpg
Must be Linux-only. Works for me on Win NT.

Comment 2

18 years ago
Mozilla/5.0 (X11; U; Linux 2.4.2 i586; en-US; rv:0.9+) Gecko/2001050808
The problem happens on my linux too.

Comment 3

18 years ago
1. When the page is downloaded, it looks like Mozilla first displays the graph,
and then "spoils" it.

2. The html source uses the following to specify the graph's gif:

<td valign=bottom><img src="/-/tmr.gif" width="4" height="13" alt="+4"></td>

I downloaded the page, changed it to src="tmp.gif", and put a tmr.gif next to
the html file. It works.

So it looks src="/-/tmr.gif" is causing the problem.

Comment 4

18 years ago
I have seen this as well, it will not display images inside tables if and only 
if it is set to pixels *NOT* percent. Percent will not work. I saw this in 
todays 2001051408 Mozilla Builds on Win 98. Marking NEW
Status: UNCONFIRMED → NEW
Component: HTMLTables → ImageLib
Ever confirmed: true
Keywords: dataloss, regression
OS: Linux → All
Hardware: PC → All
Summary: Incorrect image rendering inside tables. → Incorrect image rendering inside tables with Height set to anything but %

Comment 5

18 years ago
Reassigning.
Assignee: karnaze → pavlov
QA Contact: amar → tpreston

Comment 6

18 years ago
*** Bug 79888 has been marked as a duplicate of this bug. ***

Comment 7

18 years ago
*** Bug 79919 has been marked as a duplicate of this bug. ***

Comment 8

18 years ago
Changing based on dupes.
Summary: Incorrect image rendering inside tables with Height set to anything but % → Image does not render when Height set to anything but %

Comment 9

18 years ago
*** Bug 80174 has been marked as a duplicate of this bug. ***

Comment 10

18 years ago
changing status to [imglib]
Whiteboard: [imglib]
(Assignee)

Comment 11

18 years ago
waterson, attinasi?  any clues here?  i think this is pretty new.

Comment 12

18 years ago
> I have seen this as well, it will not display images inside tables if and 
> only if it is set to pixels *NOT* percent. Percent will not work. 

So how would you explain that it works when you only change the path from
"/-/tmr.gif" to "tmr.gif"?

I think this is a different problem, and the other bugs mentioned are not
duplicates of it. I am attaching a tar with 3 files to show this:

taiga.html - the original web page. Shows the bug.
taiga2.html - same with paths modified. Bug disappears.
tmr.gif - a small gif for taiga2.html to look nice.

Hope this helps.


Comment 13

18 years ago
Created attachment 34777 [details]
an html showing the bug, and a modified one were the bug disappears.

Comment 14

18 years ago
Your right i screwed this up changing it back...I just filed a bug for the other
problem. its bug 81254. Sorry bout the mess
Summary: Image does not render when Height set to anything but % → Image does not render when /-/ is in source

Comment 15

18 years ago
not critical for 0.9.1
Target Milestone: --- → mozilla0.9.3

Comment 16

18 years ago
Doesn't look like this is getting fixed before the freeze tomorrow night.
Pushing out a milestone.  Please correct if I'm mistaken.
Target Milestone: mozilla0.9.3 → mozilla0.9.4
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.4 → mozilla0.9.5
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.5 → mozilla0.9.7
(Assignee)

Comment 17

17 years ago
this looks like it works fine to me.  is anyone else still seeing this?
Keywords: qawanted
(Assignee)

Comment 18

17 years ago
wfm
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 19

16 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021226 Debian/1.2.1-9

Wfm (Bug URL changed to http://taiga.irk.ru/weather).
Wfm also on Windows.
Can someone close this bug?
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.