Closed Bug 796331 Opened 7 years ago Closed 4 years ago

AppManager.launch(url) should take a name as argument instead of the an url

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

defect
Not set

Tracking

(blocking-basecamp:-)

RESOLVED WONTFIX
blocking-basecamp -

People

(Reporter: ghtobz, Assigned: fabrice)

References

Details

[GitHub issue by vingtetun on 2012-01-19T08:16:39Z, https://github.com/mozilla-b2g/gaia/issues/283]
This will be much easier for us to switch to the webapps backend at the end and changing the main page of the application in the manifest won't break tests (the coming ones)
[GitHub comment by cgjones on 2012-02-18T01:48:46Z]
Is this a change you would like to see in the web apps API in gecko?

CC @fabricedesre
Duplicate of this bug: 796330
Component: Gaia → Gaia::Apps Management
Component: Gaia::Apps Management → Gaia
Component: Gaia → Gaia::Homescreen
Priority: P2 → --
Whiteboard: [label:homescreen][label:needsGeckoSupport]
Mass update: Resolve wontfix all issues with legacy homescreens.

As of 2.6 we have a new homescreen and having these issues open is confusing. All issues will block bug 1231115 so we can use that to re-visit any of these if needed.
Blocks: 1231115
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.