[browser] panning back and forth may leave graphic defect (redraw issue)

RESOLVED WORKSFORME

Status

Firefox OS
General
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: GH to BZ, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [label:browser][label:needsGeckoSupport])

(Reporter)

Description

6 years ago
[GitHub issue by nhirata on 2012-07-10T22:50:53Z, https://github.com/mozilla-b2g/gaia/issues/2310]

## Environment
* Otoro phone, build 2012-07-10
* Gaia commit: d0fc2f0cdbec7bd94d6bd3fd782803b8787f8040

## Repro
1. launch browser webapp
2. go to http://people.mozilla.com/~nhirata
3. jerk pan up down and up again

## Expected:
* no graphic defect

## Actual:
* some of the previous image still remains.  invalidation didn't occur correctly.
* screenshot : http://cl.ly/1F0r2i2P1D3c3O3d0A0h
(Reporter)

Comment 1

6 years ago
[GitHub comment by nhirata on 2012-07-10T23:17:03Z]
Going to http://people.mozilla.com/~nhirata/html_tp/bug598368.html will show a grey portion down at the bottom.  I think this is where the invalidation is not occurring correct?  I think the viewport is incorrect.
(Reporter)

Comment 2

6 years ago
[GitHub comment by benfrancis on 2012-09-14T14:38:14Z]
Marking needsGeckoSupport as this is a potential rendering problem.

@cgjones does this correspond to one of the known bugs already filed for platform?
(Reporter)

Comment 3

6 years ago
[GitHub comment by cgjones on 2012-09-14T17:47:54Z]
Yep.

Updated

6 years ago
Component: Gaia → Gaia::Browser
Sounds like this is a duplicate and is now fixed.
Component: Gaia::Browser → General
Keywords: qawanted

Comment 5

6 years ago
can't reproduce anymore
verified.
build info
2012-11-21 Unagi Daily Build
gaia : 7967ee63b77b537562d524242fe4f9dc881a39ea
releases/gecko : 372f36fb1a5d6428bcba336499abe5c2d0105433
gonk-misc : aafa9ca4d2e9e755fe9964018a9797eac4ecc7de
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.