Closed Bug 796386 Opened 7 years ago Closed 7 years ago

Warn user if bugmails have been disabled.

Categories

(Bugzilla :: User Accounts, enhancement)

enhancement
Not set

Tracking

()

RESOLVED FIXED
Bugzilla 4.4

People

(Reporter: mtyson, Assigned: mtyson)

Details

Attachments

(1 file, 2 obsolete files)

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.1 (KHTML, like Gecko) Chrome/21.0.1180.89 Safari/537.1

Steps to reproduce:

If a users account has had bugmails disabled by the administrator then they don't receive a warning stating this.  This is confusing to users as the email preferences screen will indicate that they should be receiving mails.

Attached is a proposed patch against trunk to display a warning.


Actual results:

The email preferences screen does not indicate that their bugmails have been disabled by an administrator.


Expected results:

The bugmail screen should state that they need to contact an administrator to enable mails.
Attachment #666820 - Flags: review?(glob)
Comment on attachment 666820 [details] [diff] [review]
Display a message to the user stating that bug mails have been disabled.

please use css to style, not <font color="red">
Attachment #666820 - Flags: review?(glob) → review-
Assignee: user-accounts → mtyson
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
i also think the styling should match our existing messages (see #message).
red text is used for errors, which this isn't.
Updated to use the CSS message style.
Attachment #666820 - Attachment is obsolete: true
Attachment #666824 - Flags: review?(glob)
Comment on attachment 666824 [details] [diff] [review]
Display a message to the user stating that bug mails have been disabled.

after you submit changes to your email preferences, a div with id 'message' is created with "The changes to your email preferences have been saved".

with your patch we'll end up with two divs with the same id.

perhaps we should use the warningmessages class instead?  it's very .. yellow, but seems to be the right fit function-wise.
Attachment #666824 - Flags: review?(glob) → review-
Updated to use the warningmessages class.
Attachment #666824 - Attachment is obsolete: true
Attachment #666868 - Flags: review?(glob)
Comment on attachment 666868 [details] [diff] [review]
Display a message to the user stating that bug mails have been disabled.

r=glob
Attachment #666868 - Flags: review?(glob) → review+
Severity: normal → minor
Flags: approval?
Flags: approval4.4?
Comment on attachment 666868 [details] [diff] [review]
Display a message to the user stating that bug mails have been disabled.

>+[% IF user.email_disabled %]
>+<div class="warningmessages">

Please fix the indentation on checkin:

[% IF ... %]
  <div ...>
    bla...
  </div>
[% END %]

Also, bugmail must be replaced by [% terms.bug %]mail, as we do everywhere else.
a=LpSolit with the fixes on checkin.
Severity: minor → enhancement
Flags: approval?
Flags: approval4.4?
Flags: approval4.4+
Flags: approval+
Target Milestone: --- → Bugzilla 4.4
Committing to: bzr+ssh://bjones%40mozilla.com@bzr.mozilla.org/bugzilla/trunk/
modified template/en/default/account/prefs/email.html.tmpl
Committed revision 8408.
                    
Committing to: bzr+ssh://bjones%40mozilla.com@bzr.mozilla.org/bugzilla/4.4/
modified template/en/default/account/prefs/email.html.tmpl
Committed revision 8403.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.