Homescreen displays no app icons under Firefox Nightly

RESOLVED INVALID

Status

RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: ghtobz, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [label:homescreen])

(Reporter)

Description

6 years ago
[GitHub issue by benfrancis on 2012-07-18T11:55:16Z, https://github.com/mozilla-b2g/gaia/issues/2583]
Homescreen broken when viewed in Firefox Nightly.

Environment:
Firefox Nightly running Gaia from localhost using the HTTP server setup created by Gaia build process.

Steps to reproduce:
* Run /path/to/firefox_nightly -profile /path/to/generated/profile to load system.gaiamobile.org:8080 over localhost in Nightly
* Unlock screen

Expected:
* App icons shown

Actual:
* No app icons shown
* "uncaught exception: 2147500033" in console log

@fabi1cazenave has suggested this may be related to settings. This has been broken since the Barcelona work week but has previously worked.

Updated

6 years ago
Component: Gaia → Gaia::Homescreen
Closing this as invalid as the real issue is the fact that the profile does not include the proper permissions. This is resolved with the plugin, but we should do more work to address this so we can run it without a plugin. As there are no actionable items here, I'll close this out and continue to track the issue in bug #847723.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.