[sms] if there's more than 4 lines typed in the sms sending message, the context of the text field will disappear temporarily

RESOLVED WORKSFORME

Status

Firefox OS
Gaia
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: GH to BZ, Unassigned)

Tracking

unspecified

Firefox Tracking Flags

(blocking-basecamp:-)

Details

(Whiteboard: [label:sms])

(Reporter)

Description

6 years ago
[GitHub issue by nhirata on 2012-08-08T17:54:01Z, https://github.com/mozilla-b2g/gaia/issues/3252]
## Environment :
Otoro phone, build 2012-08-07
Taken from default.xml in b2g-distro: 
* "platform_build" revision= 9d84ba558d495cb515d38bd1b4327b7bd3577854
* "gaia" revision= 8487a6683c77d28a1120342f9c3fc31be6bf63e4
* "mozilla-central" revision= 0ec22da9cb6cf5a2c2953370a4c915cae7fd5ceb
* "gonk-misc" revision= 773ceab8795053694453841ac2c5dca2d039ffa6


## Repro :
1. launch sms
2. click + to type to a person
3. in the edit message field down at the bottom, click and type:
"a
b
c
d
e"

## Expected :
*
"b
c
d
e" would be visible


## Actual :
* content becomes blank and will appear after 6 seconds

## Note :
* not sure how many people will hit this bug, noming for basecamp for second opinion... but I don't think it's serious because of the amount of lines it takes...
* suggest punting to v2?
(Reporter)

Comment 1

6 years ago
[GitHub comment by borjasalguero on 2012-08-08T20:52:48Z]
I will try to test it tomorrow again because I cant reproduce it in my device... :(!
(Reporter)

Comment 2

6 years ago
[GitHub comment by fcampo on 2012-08-09T10:18:53Z]
I just tried and I was able to reproduce it with latest build and gaia. Investigating the reasons.
(Reporter)

Comment 3

6 years ago
[GitHub comment by autonome on 2012-08-20T15:40:06Z]
Not blocking since it does sound like something that won't often happen - sms messages are short.

However, if we start hearing about this during dogfood phase, let's reconsider blocking.
(Reporter)

Comment 4

6 years ago
[GitHub comment by fcampo on 2012-08-20T15:45:06Z]
I've tested it, and it only happens when you type single letters,works ok with double or words. kinda weird.
Working properly in my Unagi device:
Test case:
-Type the following:
a
b
c
d
e
f

-Result: All letters are properly displayed. Closing!
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
I think it should be set to "works for me" if it can't be reproduced?

I can't seem to reproduce this bug again either on today's build. 11/13
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.