image borders going under inline backgrounds

RESOLVED DUPLICATE of bug 61217

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 61217
17 years ago
17 years ago

People

(Reporter: Ville J Takanen, Assigned: Pierre Saslawsky)

Tracking

({css1, testcase})

Trunk
x86
Windows 2000
css1, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Hixie-P3], URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
When using CSS to define A:Link and A:hover, image borders inside A tags behave
oddly.
See url for example.

Comment 1

17 years ago
Mozilla is rendering in Netscape quirks mode. Add DOCTYPE as per the attachment 
I'm about to make, and it works in 0.9 on Win2k exactly as it does in IE 5.01 
on Win2k. I had the same problem. Heh.

Not marking invalid, because I don't think it's my place to.
Summary: CSS styles cause image border rendering behave wrong. → CSS styles cause image border rendering behave wrong.

Comment 2

17 years ago
Created attachment 33666 [details]
'Fixed' version of the given url.
Er... The issue is just that the <a> tag is not as tall as the image, as far as
I can tell  And it's not supposed to be.

Strict mode changes nothing in the rendering, btw.

Over to style system.
Assignee: asa → pierre
Component: Browser-General → Style System
QA Contact: doronr → ian

Comment 4

17 years ago
*shrug* Adding the doctype made very definite differences to the rendering in 
0.9 on Win2k, for me. As I say - it renders exactly like IE 5.01 and IE 5.5 SP1 
with the DOCTYPE (which is, I assume, correct), and incorrectly without.

Comment 5

17 years ago
Sorry, when I say 'render', I mean that the <a> tag is the correct height, and 
so it both looks right and functions correctly.
Nik:  if you're talking about your attachment, then that's not a valid
comparison.... it has text instead of images.  Going to attach a page _just_
like the original but with a doctype.

Comment 8

17 years ago
I grabbed the thumbnails, so I <i>was</i> seeing the images, and my comments 
are based around that. I suppose I should have mentioned that. Apologies.
(Reporter)

Comment 9

17 years ago
I can see the errors still on the fixed attachment. Nik: did you copy the
mozbug.css file too?
The rendering differences of IE and Mozilla can bee seen on the url now. (I
copied the 'fixed file' and put some text between the <a></a> tags). IE marks
the a:hovers with height of the image Mozilla (0.9, windows installer, build
id:1001050515) marks only to the height of text, and marks the borders of images
pretty ugly.

Comment 10

17 years ago
Mm. I see the errors, and admit I was completely wrong about it. Now that I 
look at the CSS, I see that IE 5 isn't paying attention to any of the a: 
styles - it looks exactly the same here with or without the CSS available. This 
is what confused me, I think.

Now I'll shut up and go and do something I'm _good_ at :)
The <a> _should_ only be the height of the text, I think.  Setting status to new
so Hixie will look at it.
Status: UNCONFIRMED → NEW
Ever confirmed: true
This is indeed a bug.

Test case:
   http://hixie.ch/tests/adhoc/css/box/inline/001.html

This shows that for inline replaced blocks we are drawing the borders under the
inline element background layer, instead of on top, as with non-replaced inline 
elements. However, we only do this when the opacity is set to '1' -- looking at
the same test case with -moz-opacity: 0.99 gives:

   http://hixie.ch/tests/adhoc/css/box/inline/mozilla/001.html

See also the inline-non-replaced case:

   http://hixie.ch/tests/adhoc/css/box/inline/002.html

cc'ing dbaron who is an expert on all things painting-layer related. :-)
Severity: minor → normal
Component: Style System → Layout
Keywords: css1, mozilla1.0, testcase
Summary: CSS styles cause image border rendering behave wrong. → image borders going under inline backgrounds
Whiteboard: [Hixie-P3]
Duplicate of bug 61217, except that I don't understand what's going on with the
-moz-opacity thing.

I really should fix bug 61217 sometime...
(Assignee)

Comment 14

17 years ago


*** This bug has been marked as a duplicate of 61217 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.