Problems with compilling b2g on fedora

RESOLVED INVALID

Status

RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: ghtobz, Assigned: gsvelto)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [label:Makefile])

(Reporter)

Description

6 years ago
[GitHub issue by axel2033 on 2012-08-26T16:53:42Z, https://github.com/mozilla-b2g/gaia/issues/3842]
/usr/bin/ld: cannot find -lstdc++ 
/usr/bin/ld: cannot find -lm 
/usr/bin/ld: cannot find -lc

make[5]: *** [libs_tier_platform] Ошибка 2
make[4]: *** [tier_platform] Ошибка 2
make[3]: *** [default] Ошибка 2
make[2]: *** [realbuild] Ошибка 2
make[1]: *** [build] Ошибка 2
make: *** [out/target/product/maguro/obj/DATA/gecko_intermediates/gecko] Ошибка 2

Build failed! <
(Reporter)

Comment 1

6 years ago
[GitHub comment by jds2501 on 2012-08-27T12:25:13Z]
Can you move this issue to bugzilla and file it under Core --> Build Config?
(Reporter)

Comment 2

6 years ago
[GitHub comment by axel2033 on 2012-08-27T16:11:28Z]
No sorry I have not worked with bugzilla and at the moment I can not move this issue to bugzilla.
Can you help me here?
(Assignee)

Updated

6 years ago
Assignee: nobody → gsvelto
(Assignee)

Comment 3

6 years ago
The linker issue is caused by the 'file_id' tool requiring static versions of the 64-bit libstdc++, libc and libm libraries. It is solved by installing the libstdc++-static.x86_64 and glibc-static.x86_64 packages:

yum install glibc-static.x86_64 libstdc++-static.x86_64
Status: NEW → ASSIGNED
(Assignee)

Comment 4

6 years ago
Closing as invalid, since the issue is solved by having the proper packages installed. I've added notes on the B2G prerequisites page to inform others trying to do a build under Fedora.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
OS: All → Linux
Hardware: All → x86_64
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.