[dialer] add contacts button should be disabled when the number is empty

RESOLVED DUPLICATE of bug 813147

Status

Firefox OS
Gaia::Dialer
RESOLVED DUPLICATE of bug 813147
5 years ago
5 years ago

People

(Reporter: GH to BZ, Unassigned)

Tracking

({regression})

unspecified
regression

Firefox Tracking Flags

(blocking-basecamp:-)

Details

(Whiteboard: interaction, UX-P2)

(Reporter)

Description

5 years ago
[GitHub issue by nhirata on 2012-08-27T18:33:06Z, https://github.com/mozilla-b2g/gaia/issues/3873]
Otoro phone, build 2012-08-27
Taken from default.xml in b2g-distro: 
* "platform_build" revision= 76e88b579737d7b5078063dcbec60c2ad2c70465
* "gaia" revision= a20b169471345125092e91f981581dccd23e3371 
* "mozilla-central" revision= 1bf80bf946010db2810996225e143a3c50cede36
* "gonk-misc" revision= a9b6133e492017d34703ae3f24ea1fa9349cbcce
  
## Environment :
Otoro Self Build 8/24/2012:
b2g commit cbe973c21ad4020e6e9092abaaa92bb02cbd4800
gaia commit e2deb4ca68bf30e253600c7edbe08ca1d95071d4

## Repro :
1. go to dialer
2. press the add contact button

## Expected :
1. contacts app opens to add contact

## Actual :
1. nothing.

## Note :
(Reporter)

Comment 1

5 years ago
[GitHub comment by nhirata on 2012-08-27T18:33:29Z]
@albertopq
(Reporter)

Comment 2

5 years ago
[GitHub comment by overholt on 2012-08-30T17:56:00Z]
This works for me with the 8/30 build.
(Reporter)

Comment 3

5 years ago
[GitHub comment by nhirata on 2012-08-30T17:57:51Z]
Does not work for me still : 

Otoro phone, build 2012-08-30
Taken from default.xml in b2g-distro: 
* "platform_build" revision= 76e88b579737d7b5078063dcbec60c2ad2c70465
* "gaia" revision= 09996ee01c035b8f44933b93c3d6021604dc2146 
* "mozilla-central" revision= 4515d814900472647df92cc57eac5341418cdafd
* "gonk-misc" revision= a9b6133e492017d34703ae3f24ea1fa9349cbcce
(Reporter)

Comment 4

5 years ago
[GitHub comment by etiennesegonzac on 2012-09-03T13:11:09Z]
I've updater the issue title which was misleading.
(Reporter)

Comment 5

5 years ago
[GitHub comment by autonome on 2012-09-17T15:24:51Z]
Nice polish, but not blocking.
Duplicate of this bug: 807766

Updated

5 years ago
Component: Gaia → Gaia::Contacts

Updated

5 years ago
Component: Gaia::Contacts → Gaia::Dialer

Updated

5 years ago
Priority: -- → P1
Whiteboard: [label:dialer] → Interaction design

Comment 7

5 years ago
(In reply to GH to BZ from comment #5)
> [GitHub comment by autonome on 2012-09-17T15:24:51Z]
> Nice polish, but not blocking.

this bug is related to BugĀ 813147

referencing:
comment 1 from bug 813147
wireframe pack: HTML5_Dialer_Contacts_20120810_R2S1_V6.0
Page: 05

The functionality to disable the Add Contact button until numbers are typed is not specified. However from a UX perspective, for the purposes of error prevention, it is a pragmatic improvement of the specified functionality to disable the Add Contact button until a number is  typed. 

As an addition to this. to have a CTA that is not only seemingly tappable but also seemingly responds to being tapped, however nothing actually happens after it has been tapped is a completely unacceptable UX and devalues the end users perception of the robustness of our device. 

I would therefore propose that this bug is absolutely not 'nice polish' bug but in fact is a blocker.
Whiteboard: Interaction design → Interaction
Priority: P1 → --
Whiteboard: Interaction → interaction, UX-P2

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 813147
You need to log in before you can comment on or make changes to this bug.