Cannot drag and drop a homescreen icon with 15 icons on screen to the top row, 3rd column from the left

VERIFIED WORKSFORME

Status

VERIFIED WORKSFORME
6 years ago
6 years ago

People

(Reporter: ghtobz, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [label:homescreen])

(Reporter)

Description

6 years ago
[GitHub issue by jds2501 on 2012-08-31T19:05:20Z, https://github.com/mozilla-b2g/gaia/issues/4249]
## Build

* Device: Otoro
* Gaia: 0ea9a5c151a5f6ac2826366aeb39c73598e630fe
* Mozilla Central: fa65869284698be152dbe18af2dde0577ee65333

## Steps

1. Build a homescreen that has 15 icons showing on every spot except the row 1, column 3 location
2. Drag and drop an app icon onto that location

## Expected

The icon should be successfully dragged and dropped onto that location.

## Actual

The app icon fails to drop on that location. It reverts back its original location.
(Reporter)

Comment 1

6 years ago
[GitHub comment by crdlc on 2012-09-01T13:06:40Z]
Hi,

   I guess the problem is because there is a hidden app [1]. The solution would be implemented here [2]

if (!manifest || !manifest.icons || manifest.hidden === 'hidden') {

I'm going to solve the problem on monday or someone could apply this solution.

Thanks

[1] https://github.com/mozilla-b2g/gaia/blob/master/test_apps/image-uploader/manifest.webapp#L24
[2] https://github.com/mozilla-b2g/gaia/blob/master/apps/homescreen/js/appmanager.js#L48
(Reporter)

Comment 2

6 years ago
[GitHub comment by autonome on 2012-09-17T22:37:46Z]
PR landed, closing.

Updated

6 years ago
Component: Gaia → Gaia::Homescreen
I cannot reproduce
Keywords: qawanted
Bumping to resolved fixed per comment 2
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Keywords: qawanted
Resolution: --- → FIXED
QA verified I cannot reproduce the initial behavior that was reported either (comment 3):
- build identifier 20130112063240
- git commit df38c1bb813029f3ccfa4a997fb1529b..

Marking worksforme on today's build - I've decided not to try to repro on a ~3 month old build.
Status: RESOLVED → VERIFIED
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.