[contacts] importing from SIM card when there's no contacts will stay at "reading from SIM card"

VERIFIED FIXED

Status

Firefox OS
Gaia::Contacts
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: GH to BZ, Assigned: arcturus)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [label:contacts])

(Reporter)

Description

5 years ago
[GitHub issue by nhirata on 2012-08-31T23:33:57Z, https://github.com/mozilla-b2g/gaia/issues/4260]
## Environment :
Otoro phone, build 2012-08-31
Taken from default.xml in b2g-distro: 
* "platform_build" revision= 76e88b579737d7b5078063dcbec60c2ad2c70465
* "gaia" revision= 0ea9a5c151a5f6ac2826366aeb39c73598e630fe 
* "mozilla-central" revision= fa65869284698be152dbe18af2dde0577ee65333
* "gonk-misc" revision= a9b6133e492017d34703ae3f24ea1fa9349cbcce
  

## Repro :
1. launch contacts
2. click on import SIM contacts

## Expected :
1. 0 SIM contacts imported

## Actual :
"reading from SIM card"

## Note:
Contacts is now OOP
(Reporter)

Comment 1

5 years ago
[GitHub comment by tonychung on 2012-09-06T15:40:26Z]
still reproducing this on 9-6-2012 daily build.   My SIM card i'm using is brand new and has 0 SIM contacts, yet it sits on this screen for 5 minutes and counting...    

Can we instantiate a timeout?

Also, this app is recoverable if you want to exit, tap a contact, etc... so it's not a blocking issue.  just an annoying behavior if the user sits there and expects something to happen.
(Reporter)

Comment 2

5 years ago
[GitHub comment by arcturus on 2012-09-13T15:52:27Z]
Pending platform bug: 

https://bugzilla.mozilla.org/show_bug.cgi?id=788377
(Reporter)

Comment 3

5 years ago
[GitHub comment by albertopq on 2012-09-25T15:02:09Z]
Can QA confirm is still happening? @johnshih ?
(Reporter)

Comment 4

5 years ago
[GitHub comment by nhirata on 2012-09-26T16:05:47Z]
This is still happening.

Otoro phone, build 2012-09-26 us
Taken from default.xml in b2g-distro: 
* "platform_build" revision= 795261940c8b11fb7dddd7a8e9dd8561fdc4fb64
* "gaia" revision= 34bcd071074c4b5802195fd9173bd108e6c5891c 
* "releases-mozilla-central" revision= 35d92aa2a19da7aa89cffd7508d7d2ea40d40bc7
* "gonk-misc" revision= 1fa95341cd2bbf5d476cbcf84d03c33cd5fe66fc
(Reporter)

Comment 5

5 years ago
[GitHub comment by arcturus on 2012-09-26T23:22:02Z]
Thanks @nhirata will take a look
(Reporter)

Comment 6

5 years ago
[GitHub comment by arcturus on 2012-09-27T13:02:31Z]
Just checked and we have problems with the backend, we are always getting an error while calling to read contacts from SIM.

The bugzilla bug:

https://bugzilla.mozilla.org/show_bug.cgi?id=784646

Has been reopened, for this. Currently the frontend doesn't give any feedback of this error happening, and that's quite confusing, but the problem is coming from the backend as the read is always failing.

Cheers.
This has been fixed already fixed with new contact settings screen.
Ouch, just realised now i cannot close the bugs xD ... please someone can verify and close?

Thanks
You can place in the QA contact or cc me in the bugs and I will try to take a look at them to verify and close the bugs.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
verified

Otoro phone, build 2012-10-03 us
Taken from default.xml in b2g-distro: 
* "platform_build" revision= 795261940c8b11fb7dddd7a8e9dd8561fdc4fb64
* "gaia" revision= a3339652136fde9e5207e1bc1263a410c84f55fc 
* "releases-mozilla-central" revision= aecce9686d0b0e6ec25bb31e837eadace251a951
* "gonk-misc" revision= 202d2c62443c098b125e5d9d7b42226d98230e44
Status: RESOLVED → VERIFIED
Component: Gaia → Gaia::Contacts
You need to log in before you can comment on or make changes to this bug.