If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[contacts] Can't focus on the textbar when trying to edit it

RESOLVED FIXED

Status

Firefox OS
Gaia::Contacts
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: GH to BZ, Unassigned)

Tracking

unspecified

Firefox Tracking Flags

(blocking-basecamp:-)

Details

(Whiteboard: [label:contacts])

(Reporter)

Description

5 years ago
[GitHub issue by johnshih on 2012-09-04T07:08:46Z, https://github.com/mozilla-b2g/gaia/issues/4289]
## Environment :
Otoro phone, build 2012-09-04
Build info: 
* "gaia" revision= 180c9f54391f183c73baffbef7a6192cddbad9e8
* "gecko" revision= 4e0dac955c5009de1900873a20f6c55f8a6d1a68

## Repro :
1. Launch the contact app
2. Enter the add contact page
3. Fill the textbar with long text string, for example, email address
4. focus on it and swipe lift and right

## Expected:
* The screen will focus on the textbar and the text string will be select

## Actual:
* The screen move up and down while swiping
(Reporter)

Comment 1

5 years ago
[GitHub comment by johnshih on 2012-09-04T07:10:31Z]
found it when verify #3270
(Reporter)

Comment 2

5 years ago
[GitHub comment by johnshih on 2012-09-11T04:45:56Z]
@albertopq  can you check this?
(Reporter)

Comment 3

5 years ago
[GitHub comment by albertopq on 2012-09-11T23:43:24Z]
I think is a platform issue, but I'll check it in depth
(Reporter)

Comment 4

5 years ago
[GitHub comment by autonome on 2012-09-17T22:12:10Z]
The screen doesn't move a lot, and definitely not tracking the horizontal distance the finger is going. We can probably live with this for V1.

@albertopq @davidflanagan do you think that capturing touch events while in edit mode and input field is focused is a system workaround we could do?
(Reporter)

Comment 5

5 years ago
[GitHub comment by autonome on 2012-09-17T22:13:47Z]
To be clear, while i was able to reproduce the screen moving up/down a little, i could not reproduce the focus issue. the string was focused for me. the problem was that the very slight up/down movements were being registered by the scrolling/panning code, when they should be being ignored because a text input has focus.

Updated

5 years ago
Component: Gaia → Gaia::Contacts

Comment 6

5 years ago
It seems that this is already fixed. The remaining issue regarding scrolling is being tracked in 814252
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.