[SMS] Small zone at the center keeps repainting in SMS app

RESOLVED FIXED

Status

Firefox OS
Gaia::SMS
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: GH to BZ, Unassigned)

Tracking

({reproducible})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [label:sms])

(Reporter)

Description

6 years ago
[GitHub issue by kaichih on 2012-09-07T07:38:19Z, https://github.com/mozilla-b2g/gaia/issues/4442]
Enable repaint area option for debugging. 

STR: 
Open SMS app. 
There has a small zone at the center of the app and it keeps repainting. 

* This issue existed for a while. Not quite sure if it has duplicated case or not. I tried to search similar cases, but can't find it.
(Reporter)

Comment 1

6 years ago
[GitHub comment by borjasalguero on 2012-09-07T07:52:04Z]
I reported it to bugzilla (https://bugzilla.mozilla.org/show_bug.cgi?id=786730) one week and a half ago. This is due to 'debugging' is not taking into consideration 'z-index' properly, due to the repainting is due to there is a layer with a small gif in the middle (the area that we see as 'repainting'). Here we have the following:
- This layer with the .gif gonna dissapear due to it's a custom 'prompt', so once we have our 'prompt system' landend this layer will not be there anymore.
- Main issue here is that 'debugging' should only take into consideration the areas which are in the screen, not layers with a lower z-index.

Comment 2

6 years ago
[mass adding reproducible keyword for any open Gaia bug with the word "STR:" in comments]
Keywords: reproducible

Updated

6 years ago
Component: Gaia → Gaia::SMS
It was fixed last week. Closing.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.