[keyboard] Word suggestion only works for English (non dvorak)

RESOLVED DUPLICATE of bug 799013

Status

P1
normal
RESOLVED DUPLICATE of bug 799013
6 years ago
6 years ago

People

(Reporter: ghtobz, Assigned: ckerschb)

Tracking

unspecified

Firefox Tracking Flags

(blocking-basecamp:-)

Details

(Whiteboard: [label:Keyboard & IME][label:feature])

(Reporter)

Description

6 years ago
[GitHub issue by nhirata on 2012-09-12T21:52:29Z, https://github.com/mozilla-b2g/gaia/issues/4663]
## Environment :
Otoro phone, build 2012-09-12
Taken from default.xml in b2g-distro: 
* "platform_build" revision= 1532e3d7099724a8701da220ce29e705a33f78eb
* "gaia" revision= 0ec99508cc5198ff0908a85ab624f8bf08f28e31 
* "mozilla-central" revision= 0ce1f32125257961232c65c7d6251314f9e0f2be
* "gonk-misc" revision= ec56d3ede37a051321ea7c1973b5c29ef53a88db
  

## Repro :
1. go to settings
2. go to keyboard
3. select English (Dorvak) or anyother language
4. turn on word suggestion
5. disable English keyboard
6. hit home
7. launch browser
8. go to http://people.mozilla.com/~nhirata/html_tp/formsninput.html
9. click in a text field
10. type "hel"

## Expected :
1. word suggestions

## Actual :
1. no word suggestions

## Note :
(Reporter)

Comment 1

6 years ago
[GitHub comment by autonome on 2012-09-21T16:40:35Z]
/cc @gregorwagner in case @ckerschb can't work on it.
(Reporter)

Comment 2

6 years ago
[GitHub comment by ckerschb on 2012-09-21T23:07:02Z]
@RudyLu can you please take a look at this, I just did a brief test and it also doesn't work for other layouts. It seems to be a keyboard issue because the function PTW_key() is not triggered and therefore the keyCode is not passed on to the prediction engine.

Comment 3

6 years ago
Do we have dictionary support for Portuguese or Spanish?
Priority: -- → P1
Closing this as a dupe.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 799013

Updated

6 years ago
blocking-basecamp: + → -
You need to log in before you can comment on or make changes to this bug.