If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Settings] WiFi shows "connecting to null..." message when Airplane Mode is turned On

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Settings
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: GH to BZ, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [label:settings][label:networking][label:system/notification])

(Reporter)

Description

5 years ago
[GitHub issue by pragmatictester on 2012-09-13T02:19:24Z, https://github.com/mozilla-b2g/gaia/issues/4668]
## Build

* Device: Otoro
* Nightly Build: Sep 11, 2012
* Gaia: 6cb41da
* Mozilla-central: 105845c

## Steps

1. Go to the homescreen
2. Pull down the Utility Bar
3. Click on Settings.
4. Go to the Network & Connectivity section.
5. Toggle the Airplane Mode so that it is On. Select a WiFi network and connect to it.
6.  Toggle the Airplane Mode so that it is Off. 

## Expected

WiFi turns off and shows the message "Disabled".


## Actual

WiFi shows a series of messages one of which is "connecting to null...".

## Screenshot
<img src="http://cl.ly/JROt/connecting_to_null.png" />
FWIW, I see this same status ("connecting to null") when I turn on my screen again after the screen's been off for long enough to make the wifi auto-disconnect (maybe 5 min).

Updated

5 years ago
Component: Gaia → Gaia::Settings
Unable to reproduce with latest master.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.