Closed Bug 796686 Opened 8 years ago Closed 8 years ago

[Settings] Need 2G/3G preferred network type selection UI

Categories

(Firefox OS Graveyard :: Gaia, defect, P1)

defect

Tracking

(blocking-basecamp:+)

VERIFIED FIXED
B2G C1 (to 19nov)
blocking-basecamp +

People

(Reporter: ghtobz, Assigned: kaze)

References

Details

(Keywords: feature, Whiteboard: [label:settings][label:needsGeckoSupport][label:needsUXinput][label:telephony][label:feature])

Attachments

(1 file)

[GitHub issue by vicamo on 2012-09-20T04:13:31Z, https://github.com/mozilla-b2g/gaia/issues/4944]
[Bugzilla 787420](https://bugzilla.mozilla.org/show_bug.cgi?id=787420) implements preferred network type selection by introducing new Settings API key "ril.radio.preferredNetworkType", possible values "gsm", "wcdma" and "wcdma/gsm". A debug is also available in the same page for function tests.
[GitHub comment by autonome on 2012-09-26T06:39:14Z]
We don't support CDMA for v1. Why does this block the release?
[GitHub comment by vicamo on 2012-09-26T17:08:13Z]
W-CDMA is not CDMA. Well, that's a long story, but it's the 3G network you used and GSM is the 2G one currently on B2G.
[GitHub comment by caseyyee on 2012-09-26T19:26:30Z]
In what cases would a user need to switch network types?   I would think that this should be automatic and always default to the fastest available network type.

If we need a control like this, it would make sense to put it into Settings -> Cellular & Data.

@lco?
[GitHub comment by lco on 2012-09-26T23:13:55Z]
We could put it in the advanced section of Cellular/Data. See pg. 27: http://people.mozilla.com/~lco/Settings_B2G/Release_1_Specs/R1_Connectivity_v10.pdf

But please let me know if this is definitely a requirement for v1.
[GitHub comment by evelynhung on 2012-09-27T11:33:47Z]
Is #3649 the same issue?
[GitHub comment by caseyyee on 2012-09-27T18:38:03Z]
@evelynhung this is a different issue.   The use case here is that switching to 2G could save battery life.

@clee can you confirm that this is required for V1?
[GitHub comment by clee on 2012-09-27T19:46:03Z]
@caseyyee Wrong clee. @cleemoz is the one you want :)
[GitHub comment by cleemoz on 2012-09-29T01:30:02Z]
I'd kick this to @dcoloma -- can you confirm if we need a 2G/3G toggle?
As a user, I would definitely love that feature, but I want to check if this a must have for device certification. 

Will come back to you soon.
We have just confirmed that it is a certification requirement.
I just want to emphasize that this setting must have three options and user must choose 1:
- Automatic mode: 2G/3G (default value)
- Only 2G
- Only 3G
Taking this, and will update the spec soon.
Assignee: nobody → lco
Dietrich, can you please assign to the engineer who'll work on this? The spec is finished.
Flags: needinfo?(dietrich)
Assignee: lco → nobody
Flags: needinfo?(dietrich)
Tentatively assigning Kaze... Kaze, do you think you can take this? Thanks!
Assignee: nobody → kaze
@philikon the front-end side is trivial, but I’m not sure about the back-end side. If you feel confident about this I can do what it takes to make it work — including working a couple weeks in California.
(In reply to Fabien Cazenave [:kaze] from comment #16)
> @philikon the front-end side is trivial, but I’m not sure about the back-end
> side.

What besides bug 787420 is needed? I was under the impression we just need to implement a UI for the setting at this point.
If the back-end’s ready, that should be easy. Lemme see.
Awesome. Thanks! Basically, the 'ril.radio.preferredNetworkType' setting can be one of these values:

  const GECKO_PREFERRED_NETWORK_TYPE_WCDMA_GSM = "wcdma/gsm";
  const GECKO_PREFERRED_NETWORK_TYPE_GSM_ONLY = "gsm";
  const GECKO_PREFERRED_NETWORK_TYPE_WCDMA_ONLY = "wcdma";
Depends on: 787420
Priority: P1 → --
Priority: -- → P1
On latest build i tried changing the network from GSM to WCDMA using setting 'ril.radio.preferredNetworkType'   and it works fine, but the data type is not changing from E to H.
Blocks: 808207
Duplicate of this bug: 808874
We're marking this bug with the C1 milestone since it follows the criteria of "unfinished feature work" (see https://etherpad.mozilla.org/b2g-convergence-schedule).

If this work is not finished by Nov19, this bug will need an exception and will be called out at the upcoming Exec Review.
Target Milestone: --- → B2G C1 (to 19nov)
kaze, whats the status here?
Keywords: feature
I’m finishing another bug atm, this one is next on my list. Should be done today.
Attached file layout fixes
Attachment #679832 - Flags: review?(philipp)
Attachment #679832 - Flags: review?(philipp) → review+
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
This issue fixed for  device Ungia; build #20121231070201 v.1
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.