[marketplace] not possible to log in to marketplace (login button does not work)

RESOLVED WORKSFORME

Status

Firefox OS
Gaia
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: GH to BZ, Unassigned)

Tracking

unspecified

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Whiteboard: [label:market])

(Reporter)

Description

5 years ago
[GitHub issue by jammink on 2012-09-20T21:02:19Z, https://github.com/mozilla-b2g/gaia/issues/4989]
## Environment
* gaia - 3d5b85ec446ca2625a 
* daily build 2012-09-20


## Repro
1. Launch marketplace app.
2. click "Log into Marketplace".
3. on persona site, enter email address, click next
 
## Expected
* login to market proceeds normally and marketplace loads.

## Actual
* nothing happens.  Tapping it a second time launches the keyboard.  Ultimately it's not possible to log into the marketplace this way.
(Reporter)

Comment 1

5 years ago
[GitHub comment by jds2501 on 2012-09-20T21:16:47Z]
@krupa Thinks this is a persona bug.
(Reporter)

Comment 2

5 years ago
[GitHub comment by jammink on 2012-09-20T21:23:13Z]
@jrgm
(Reporter)

Comment 3

5 years ago
[GitHub comment by jds2501 on 2012-09-20T21:23:16Z]
@jammink Dug into this with me. This looks like a hit-range issue with the cursor - clicking the "sign in" button actually refocuses the text field for password instead. As a result, it's quite difficult to actually be able to sign in through clicking the sign in button.

My hunch is this is a keyboard Gaia bug, but I'm not 100% sure. @autonome?
(Reporter)

Comment 4

5 years ago
[GitHub comment by jammink on 2012-09-20T21:39:15Z]
After another reboot I eventually WAS able to log in (?) somehow to marketplace and get an app installed.  Not sure about the keyboard issue but a reboot have have cured that symptom.  (On a side note, we now log the number of reboots it takes to get through a smoketest cycle for this very reason!)

I can reproduce this issue again on a phone in low memory state.   But as it does not happen after a fresh boot at least it's not blocking :-/
(Reporter)

Comment 5

5 years ago
[GitHub comment by autonome on 2012-09-25T23:09:01Z]
@RudyLu is this a keyboard issue?
(Reporter)

Comment 6

5 years ago
[GitHub comment by RudyLu on 2012-09-26T03:32:26Z]
Works for me. 
Is this issue still reproducible?
(Reporter)

Comment 7

5 years ago
[GitHub comment by autonome on 2012-09-26T06:40:22Z]
I can reproduce. the hit target in both the email and password fields are incorrect when you try to login to marketplace. you can only log in by hitting enter in keyboard when you're done filling out those fields.
(Reporter)

Comment 8

5 years ago
[GitHub comment by benadida on 2012-09-27T19:44:55Z]
@autonome is this on device? Not sure how to fix that, since it works on all other platforms. Can we get guidance on what we'd need to do differently?
I can reproduce. I have to click above the form field in order to focus on the password field. This is definitely an issue with the Persona shim.
Whiteboard: [label:browser][label:market] → [label:market]
(In reply to Chris Van Wiemeersch [:cvan] from comment #9)
> I can reproduce. I have to click above the form field in order to focus on
> the password field. This is definitely an issue with the Persona shim.

Is this on device, in desktop build, or on something other than B2G?
qawanted. Jason, John or Krupa - can you try this on a supported device?
Keywords: qawanted

Updated

5 years ago
QA Contact: jsmith
I can't reproduce this on the 10/18 build. I don't think smoke tests have flagged this either in a while. Closing as a worksforme.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME

Updated

5 years ago
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.