[Settings]:Wifi got wrong state after quickly tapping Airplane Mode.

RESOLVED DUPLICATE of bug 806003

Status

RESOLVED DUPLICATE of bug 806003
6 years ago
6 years ago

People

(Reporter: ghtobz, Assigned: kgrandon)

Tracking

unspecified

Firefox Tracking Flags

(blocking-basecamp:-)

Details

(Whiteboard: [label:settings])

(Reporter)

Description

6 years ago
[GitHub issue by msliu on 2012-09-21T11:04:34Z, https://github.com/mozilla-b2g/gaia/issues/5017]
Method to reproduce this issue:
1. Go to Settings and connected to a AP like "Mozilla Guest"
2. Quickly tapping Airplane Mode in a short period time like less than 1 second. Tapping for 4~5 times.
3. Make sure Fright Mode is off.

Expected Result: Wifi automatically reconnect to AP.

Actual Result: Wifi state is off. But the device still can automatically connect to AP when tapping Wifi to on.
blocking-basecamp: --- → ?
Not easily reproductible
blocking-basecamp: ? → -

Updated

6 years ago
Component: Gaia → Gaia::Settings
I found a similar behaviour doing the same thing but with Flight Mode on: Wifi is sometimes enabled....

This is confusing but this is minor imho.
blocking-basecamp: - → ?
blocking-basecamp: ? → -
(Assignee)

Comment 3

6 years ago
We are essentially tracking the same thing in bug #806003. Marking as duplicate. (A pull request to fix that one has been opened).
Assignee: nobody → kgrandon
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 806003
You need to log in before you can comment on or make changes to this bug.