[SMS] [Contacts] Contacts created through SMS app lose their photos

VERIFIED FIXED

Status

VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: ghtobz, Assigned: alberto.pastor)

Tracking

unspecified

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Whiteboard: [label:contacts][label:sms])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

6 years ago
[GitHub issue by adityab on 2012-09-30T22:06:03Z, https://github.com/mozilla-b2g/gaia/issues/5553]
1. Open SMS app.
2. Click a thread without any contact associated with it, to open it.
3. Click the opened thread's header - this opens a page to create a new contact from that number.
4. Add name and pick photo. Save - you go back to the SMS app.

The contact's name is visible now but no photo.
Open the Contacts app, again, name is visible but no photo.

Creating a contact normally from the Contacts app works totally fine.
(Reporter)

Comment 1

6 years ago
[GitHub comment by borjasalguero on 2012-10-01T06:38:11Z]
@adityab In SMS App you mean that the photo is not rendered properly in 'Thread list' or in the detail of a 'Thread' (where you have all messages of a thread)? In SMS App everytime we have a 'visibility' event when we check all the info from contacts in order to ensure that this info is up-to-date (if you change the name, carrier or photo it should be visible in SMS App), but It's quite weird if the contact that you created has no photo in Contact App as well... Could you specify the version of Gecko/Gaia por testing the same? Thanks!

@albertopq @arcturus Any ideas?
(Reporter)

Comment 2

6 years ago
[GitHub comment by adityab on 2012-10-01T07:03:45Z]
@borjasalguero :

Commit `4b2dadb270` for Gaia, I updated Gecko ~36 hours ago.

Yeah, the photo is not rendered in the ThreadListUI.
(Reporter)

Comment 3

6 years ago
[GitHub comment by arcturus on 2012-10-01T10:27:38Z]
Hi folks, will take a look.

Thx.
QA Contact: mozillamarcia.knous
Assignee: nobody → fbsc
blocking-basecamp: ? → +
(Assignee)

Comment 4

6 years ago
Created attachment 670873 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/5594

Pointer to Github pull-request
(Assignee)

Updated

6 years ago
Attachment #670873 - Flags: review?(arcturus)
(Assignee)

Updated

6 years ago
Assignee: fbsc → alberto.pastor
(Assignee)

Updated

6 years ago
Attachment #670873 - Flags: review?(arcturus)
(Assignee)

Updated

6 years ago
Attachment #670873 - Attachment is obsolete: true
(Assignee)

Comment 5

6 years ago
Created attachment 670886 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/5793

Pointer to Github pull-request
(Assignee)

Updated

6 years ago
Attachment #670886 - Flags: review?(arcturus)
Attachment #670886 - Flags: review?(arcturus) → review+
Landed:

https://github.com/mozilla-b2g/gaia/commit/85c50bd9767552284ee1abb5bda620bd3723e4fb
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Comment 7

6 years ago
This is still an issue for  device Ungia; build #20130102070202 v.1. 
Actual result is unable to add a picture to contact at all from Gallery or Camera.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to Misty Byrd from comment #7)
> This is still an issue for  device Ungia; build #20130102070202 v.1. 
> Actual result is unable to add a picture to contact at all from Gallery or
> Camera.

Hey. This bug has been closed since 2 months so what you see is likely a different bug than what has been done here. Can you open a new bug with a new steps to reproduce in order to track the new issue?
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Flags: needinfo?(mbyrd)
Resolution: --- → FIXED

Comment 9

6 years ago
Refer to bug https://bugzilla.mozilla.org/show_bug.cgi?id=826391 for resolution to this issue per comment 8
Status: RESOLVED → VERIFIED
Flags: needinfo?(mbyrd)
You need to log in before you can comment on or make changes to this bug.