[System][FM Radio] System complete hangs/reboots when closing FM Radio while it's playing in the background.

RESOLVED WORKSFORME

Status

Firefox OS
General
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: GH to BZ, Assigned: slee)

Tracking

({hang})

unspecified

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Whiteboard: [label:system][label:FM Radio])

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
[GitHub issue by nhirata on 2012-10-01T23:13:26Z, https://github.com/mozilla-b2g/gaia/issues/5607]
## Environment :
Otoro phone, build 2012-10-01 us
Taken from default.xml in b2g-distro: 
* "platform_build" revision= 795261940c8b11fb7dddd7a8e9dd8561fdc4fb64
* "gaia" revision= 5feb07b511ab907942731fc4961ccbce3958d021 
* "releases-mozilla-central" revision= 80b40bba7f30f6cea5cb148cbbdcbf008691972b
* "gonk-misc" revision= 202d2c62443c098b125e5d9d7b42226d98230e44
  
## Repro :
1. launch FM Radio
2. play radio
3. hit home
4. launch clock
5. long tap home
6. scroll over to FM Radio (touch the very bottom and slide to FM radio)
7. slide FM radio up to close it

## Expected :
1. FM Radio closes

## Actual :
1. FM Radio is half off the list and the system hang until it reboots

## Note :

Updated

6 years ago
blocking-basecamp: ? → +
Keywords: hang
Steve, this seems to be a platform issue. My phone slows down as I start playing the radio; it rebooted even before I tried to kill the FM radio app. 

Can you take a look? Thanks.
Assignee: nobody → slee
Component: Gaia → General
Is it a dup of bug 800263?
(Assignee)

Comment 6

6 years ago
(In reply to Shih-Chiang Chien [:schien] from comment #5)
> Is it a dup of bug 800263?

It should be a dup. I am working on bug 800263. If bug 800263 is finised, I will check whether it solves this problem, too.
(Assignee)

Comment 7

6 years ago
Hi nhirata,
Can you confirm this bug? After bug 800263 landed, I cannot re-produce it on my device.
Thanks.
Lawrence just tried reproducing this on an Unagi with 2012-11-14 and couldn't.  Please re-open if you can reproduce.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.