If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Homescreen] crash occurs after swiping to another screen after deleting an app

VERIFIED FIXED

Status

Firefox OS
Gaia
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: GH to BZ, Assigned: vingtetun)

Tracking

({crash})

unspecified
crash

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Whiteboard: [label:homescreen])

(Reporter)

Description

5 years ago
[GitHub issue by nhirata on 2012-10-01T23:45:43Z, https://github.com/mozilla-b2g/gaia/issues/5608]
## Environment :
Otoro phone, build 2012-10-01 us
Taken from default.xml in b2g-distro: 
* "platform_build" revision= 795261940c8b11fb7dddd7a8e9dd8561fdc4fb64
* "gaia" revision= 5feb07b511ab907942731fc4961ccbce3958d021 
* "releases-mozilla-central" revision= 80b40bba7f30f6cea5cb148cbbdcbf008691972b
* "gonk-misc" revision= 202d2c62443c098b125e5d9d7b42226d98230e44
  
## Repro :
1. launch market
2. install an app
3. long tap on app 
4. tap on x to delete the app
5. swipe the screen right or left while still in edit mode

## Expected :
1. swipes to the search or second page

## Actual :
1. homescreen page doesn't move
2. enough swipes left and right will cause homescreen to crash

## Note :
* logcat : https://gist.github.com/3815233

Updated

5 years ago
Assignee: nobody → 21
blocking-basecamp: ? → +
Keywords: crash
Depends on: 795164
There is a good chance this is caused by #795164
Seems to work now.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Otoro phone, build 2012-10-21
Taken from default.xml in b2g-distro: 
* "platform_build" revision= 0d6d050bc37d3167cc82a1885fd7660456bb0f4e
* "gaia" revision= 6a02c47d779ee137c889e5de97fce7ca9a3a31dc 
* "releases-mozilla-aurora" revision= c4a0890132bf66e9db27b777ea1df6713254a0b0
* "gonk-misc" revision= da6e50508245d023166e0c04369200e5bb898220
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.