Set correct OS for show-for on mobile and desktop articles

RESOLVED FIXED in 2012Q4

Status

support.mozilla.org
Knowledge Base Software
P1
normal
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: atopal, Assigned: rrosario)

Tracking

unspecified
2012Q4

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: u=user c=wiki p=1 s=2012.19)

(Reporter)

Description

6 years ago
1. When you are viewing a desktop article, "Android" shouldn't be a {for} selection. Instead use windows.

2. When you are viewing a mobile article, "Windows, Mac and Linux" shouldn't be a {for} selection. Instead use Android.
(Reporter)

Updated

6 years ago
Priority: -- → P1
(Assignee)

Comment 1

6 years ago
What do we do for articles (like sync related) that have both products?
(Assignee)

Updated

6 years ago
Assignee: nobody → rrosario
(Assignee)

Updated

6 years ago
Target Milestone: --- → 2012Q4
(Assignee)

Comment 2

6 years ago
I am going to optimistically make this a 1pter
Whiteboard: u=user c=wiki p= → u=user c=wiki p=1
(Assignee)

Comment 4

6 years ago
Landed in prod:

https://github.com/mozilla/kitsune/commit/c268fff5af1b6737d2c5d693152dd1037ef94d29
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Updated

6 years ago
Depends on: 799104
I just reverted this, so I'm reopening for now until it re-lands.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Now in a new pull request: https://github.com/mozilla/kitsune/pull/891

Also, seems like this doesn't really depend on bug #799104. Why did that get added?
(Assignee)

Comment 7

6 years ago
Definitely doesn't block bug 799104, it just causes it to be an issue that didn't exist without this.
No longer depends on: 799104
(Assignee)

Comment 8

6 years ago
The revert got reverted and deployed:
https://github.com/mozilla/kitsune/commit/a3d0f6bfde1f5912af3aee58bc0b11fdccd8855c
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
(Assignee)

Updated

6 years ago
Duplicate of this bug: 799098
Adding s= sprint information to whiteboard.
Whiteboard: u=user c=wiki p=1 → u=user c=wiki p=1 s=2012.19
You need to log in before you can comment on or make changes to this bug.