Closed Bug 797087 Opened 9 years ago Closed 9 years ago

Image display (image only, no HTML) is wrong

Categories

(Core :: Layout, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 713230

People

(Reporter: bugspam, Unassigned)

Details

Action:

I followed an image link.

What happened:

The image was centred with a pale background, surrounded by a dark grey background. Examination of the generated HTML suggests that this is intended behaviour; however, , but it appears hard-wired.

What was expected:

The image should have been displayed with no defined background colour, with the body background being that defined in the browser settings, i.e. as in Firefox 10.

What to do?

For something like this, I'd expect either a configuration option or some obvious way to restyle it using a user stylesheet. I see a way to do this for the <img> (class="decoded"), but not for the <body>.

I note that Chromium (v21, at least) just displays the image without trying to do anything annoyingly fancy with it. That's the behaviour which I expect of any browser.
Component: Untriaged → Layout
Product: Firefox → Core
Please find the existing bugs on this (wontfix or invalid, I suspect) and mark this duplicate.
Whiteboard: DUPEME
(though I don’t really like the duping around that bug, because default != custom)
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 713230
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.