Browser crashes with missing symbol when loading first page

VERIFIED WORKSFORME

Status

SeaMonkey
General
--
blocker
VERIFIED WORKSFORME
17 years ago
13 years ago

People

(Reporter: Jeffrey Baker, Assigned: Chris McAfee)

Tracking

({crash, smoketest})

Trunk
x86
Linux
crash, smoketest

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Linux trunk build 2001-05-09-07.  The browser crashes whenever the first page
starts to load.  This error is spat upon the console:

mozilla/mozilla-bin: error while loading shared libraries:
/home/jwb/mozilla-gcc295/components/libgkcontent.so: undefined symbol:
GetService__16nsServiceManagerRC4nsIDRC4nsIDPP11nsISupportsP19nsIShutdownListener

smoketest
(Reporter)

Updated

17 years ago
Keywords: crash, smoketest

Comment 1

17 years ago
I can confirm this. With build 2001-05-09-07 on Debian GNU/Linux 2.2r3 I receive
this error to the console when trying to start up mozilla.

./mozilla-bin: error in loading shared libraries:
/u/pbaker/mozilla/mozilla/components/libgkcontent.so: undefined symbol:
GetService__16nsServiceManagerRC4nsIDRC4nsIDPP11nsISupportsP19nsIShutdownListener

Comment 2

17 years ago
Same error on Slackware 7.1.

Comment 3

17 years ago
Sorry to spam this bug, but I installed from the full self-extracting
installer.  A co-worker of mine with an identical setup installed from the
tarball and had no problems.
(Reporter)

Comment 4

17 years ago
I installed the tarball and it didn't work.  I use slackware-current.
yup, crashes for me using the tarball [non-installer]. using RH 6.2. get the
following console output:

nsNativeComponentLoader:
SelfRegisterDll(/home/orca/mozilla-builds/2001050908/mozilla/components/libgklayout.so)
Load FAILED with error:
/home/orca/mozilla-builds/2001050908/mozilla/components/libgklayout.so:
undefined symbol:
GetContentAndOffsetsFromPoint__7nsFrameP14nsIPresContextRC7nsPointPP10nsIContentRiN24
**************************************************
./mozilla-bin: error in loading shared libraries:
/home/orca/mozilla-builds/2001050908/mozilla/components/libnsappshell.so:
undefined symbol:
CreateInstance__18nsComponentManagerRC4nsIDP11nsISupportsRC4nsIDPPv

Comment 6

17 years ago
It might be worth noting that I get the same error as Sarah - which is slightly different from
the initial reports here, and I get this error long before the first window ever shows up. I am
running Redhat Linux (6.1) as well.

Comment 7

17 years ago
reassign to vishy for browser area.  cc: mcafee
Win32 is fine.  Mac has a different problem in today's build - unable to install
which jj has just fixed.
Assignee: asa → vishy

Comment 8

17 years ago
Same problems for me. It workes with 2001-05-07-08.
(Reporter)

Comment 9

17 years ago
Since the compiler changed, perhaps we all ought to report our systems:

glibc 2.2.2
binutils 2.10.1.0.4
libstdc++ 6.2-2, 6.1-2, and 6.1-1 all available

Comment 10

17 years ago
Nobody went and did something rash, like upgrading the build machines to
gcc-2.96, did we?...
my Red Hat 6.2 box's info:

egcs-2.91.66
glibc-2.1.3-15
binutils-2.9.5.0.22-6
libstdc++-2.9.0-30
libstdc++-2.95.2-7mdk
(Assignee)

Comment 12

17 years ago
taking this from vishy
Assignee: vishy → mcafee

Comment 13

17 years ago
the stdc++ libraries on the build machine wer just reverted this morning to
something that works on out-of-the-box redhat machines again, but i don't think
this is the cause of the problem.
the 2001.05.09.10 bits [tarball, non-installer] wfm now. anyone else having
problems with the latest verif bits?

Comment 15

17 years ago
the latest bits were done cleanly, so i think the library-change was the problem
for the 8am builds. Please use the latest linux bits!

Comment 16

17 years ago
based on latest commments, 2001-05-09-10-trunk mozilla bits work fine.
-> moving to Bugscape (#4913) to keep track of commercial core dump.

Can we consider this fixed then ?
(Assignee)

Comment 17

17 years ago
This looks like a wfm, my clobber build works fine.
I recommend clobbering, pulling down more-recent bits,
and doing the usual cache/component.reg/profile purges
if needed.  WFM.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 18

17 years ago
...and vrfy.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.