Form on VIA Rail Canada site not rendering properly (TypeError: Value not an object)

RESOLVED FIXED in Firefox 18

Status

()

Core
DOM
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: mcote, Assigned: Ms2ger)

Tracking

({regression})

18 Branch
mozilla18
x86_64
Linux
regression
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox16 unaffected, firefox17 unaffected, firefox18+ fixed)

Details

Attachments

(4 attachments)

(Reporter)

Description

6 years ago
Created attachment 667144 [details]
Broken form, Nightly 18.0a (2012-10-02)

I tried to book a train through VIA Rail Canada today, and a bug in the former parsing rendered this impossible. I was able to use release firefox with no problems. I am using nightly 18.0a1 2012-10-02.

Steps:

* Go to www.viarail.ca
* Use the form on the left to start the booking process, e.g. MONTRÉAL, QC to TORONTO, ON, departure date 11/09/2012, return date 11/10/2012, 1 adult.
* Click search.
* Pick a train, e.g. 6:20 am supersaver economy.
* Click continue at bottom of table.
* Pick another train, e.g. 6:40 am supersaver economy.
* Click continue at bottom of table.
* On next screen, click Continue at bottom.

Expected:

The form displays normally with no repeated fields and the ability to choose a Province / State.

Actual:

The two phone number fields are duplicated. The next above it reads "Phone Number
(Country code) Phone Number *" and "Cell Phone Number (Country code) Cell Phone Number". There are four entry boxes for each phone number instead of two. Most importantly, the Province / State drop down has only one option, "empty". Selecting another country, e.g. United States, does not change this. The Continue button will not work without a valid province/state selected.

I am attaching screenshots of the broken nightly and the working release (v15.0.1)
(Reporter)

Comment 1

6 years ago
Created attachment 667145 [details]
Working form, Release 15.0.1 (Ubuntu 12.04 32-bit)

The screenshot from Release firefox was actually taken on a different computer. Same OS (Ubuntu 12.04) except that Nightly is running on a 64-bit system and Release on a 32-bit.
(Reporter)

Comment 2

6 years ago
*Bug in the form parsing, not former parsing.

Comment 3

6 years ago
It's a regression from yesterday:

m-c
2012-10-01
2012-10-02
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=beee809b7ade&tochange=85dd8e346102
tracking-firefox18: --- → ?
Keywords: regression, regressionwindow-wanted

Comment 4

6 years ago
It looks like an issue with parsing style="DISPLAY: inline;".

Comment 5

6 years ago
Created attachment 667438 [details]
archive zip, Open index.html

An error in Error Console

Error: TypeError: Value not an object.
Source file: https://reservia.viarail.ca/include/js/functions.js?_=1.60.1
Line: 110


Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/1caa3c482541
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20121001015518
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/64236acfaa80
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20121001021018
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=1caa3c482541&tochange=64236acfaa80
Component: HTML: Parser → DOM
Keywords: regressionwindow-wanted
(Assignee)

Comment 6

6 years ago
Peter, looks like you didn't update your IDL file after <https://www.w3.org/Bugs/Public/show_bug.cgi?id=18503> was fixed.
(Assignee)

Updated

6 years ago
Duplicate of this bug: 797372
Summary: Form on VIA Rail Canada site not rendering properly → Form on VIA Rail Canada site not rendering properly (TypeError: Value not an object)
(Assignee)

Updated

6 years ago
Assignee: nobody → Ms2ger

Updated

6 years ago
status-firefox16: --- → unaffected
status-firefox17: --- → unaffected
status-firefox18: --- → affected
tracking-firefox18: ? → +

Updated

6 years ago
Blocks: 791774
(Assignee)

Comment 8

6 years ago
Created attachment 667562 [details] [diff] [review]
Patch v1
Attachment #667562 - Flags: review?(bzbarsky)
Comment on attachment 667562 [details] [diff] [review]
Patch v1

r=me.  It gladdens my heart to see how much code change was involved here.  ;)
Attachment #667562 - Flags: review?(bzbarsky) → review+

Updated

6 years ago
Duplicate of this bug: 798542
(Assignee)

Comment 11

6 years ago
https://hg.mozilla.org/mozilla-central/rev/416356bb2602
Status: NEW → RESOLVED
Last Resolved: 6 years ago
status-firefox18: affected → fixed
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla18
You need to log in before you can comment on or make changes to this bug.