Work - External link clicks from metro apps occasionally don't open in the browser

RESOLVED FIXED

Status

Firefox for Metro
General
RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: jimm, Assigned: jimm)

Tracking

Trunk
x86_64
Windows 8.1

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: feature=work [completed-elm])

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
STR:

1) launch metrofx
2) switch to start
3) open the weather app, page over once, click on the credits link at the bottom

results:
Metro flips to metrofx, but occasionally a new tab doesn't open and the weather links page doesn't load.

In debugging this, I've found the link actually does load, but a new tab isn't created. The link appears to load in a hidden tab or window.
Whiteboard: [metro-beta]
(Assignee)

Updated

5 years ago
Component: General → General
Product: Firefox → Firefox for Metro

Updated

5 years ago
Whiteboard: [metro-beta] → [metro-mvp]
Depends on: 801005
Whiteboard: [metro-mvp] → [metro-mvp][LOE:2]
(Assignee)

Comment 1

5 years ago
This is really easy to reproduce in slower debug builds.
(Assignee)

Updated

5 years ago
Assignee: nobody → jmathies

Comment 2

5 years ago
I've been getting this consistently since late November. Clicking links from other Metro applications successfully opens Firefox, but the page on the other side of the link doesn't appear at all, nor does a tab appear for the page.
I think maybe what you were seeing here Jim is Bug 817641.  Can you confirm if that is / is not the case?  If so I'll take bug 817641 in it2.
(Assignee)

Comment 4

5 years ago
I still see this, just tested. Same STR. In the console I see:

Activation argument kind: Protocol
'firefox.exe' (Win32): Loaded 'C:\Program Files (x86)\Internet Explorer\ieproxy.dll'. Symbols loaded.
mozilla::widget::winrt::FrameworkView::PerformURILoad
PerformURILoad uri=
[JavaScript Error: "[Exception... "Component returned failure code: 0x804b000a (NS_ERROR_MALFORMED_URI) [nsICommandLine.resolveURI]"  nsresult: "0x804b000a (NS_ERROR_MALFORMED_URI)"  location: "JS frame :: file:///T:/Mozilla/ELM-REL/dist/bin/metro/components/BrowserCLH.js :: resolveURIInternal :: line 25"  data: no]" {file: "file:///T:/Mozilla/ELM-REL/dist/bin/metro/components/BrowserCLH.js" line: 25}]
MetroWidget::Create
MetroWidget::GetDPI
MetroWidget::GetDPI
[JavaScript Warning: "Unknown property 'box-sizing'.  Declaration dropped." {file: "chrome://browser/skin/platform.css" line: 342}]
[JavaScript Warning: "Unknown property 'box-sizing'.  Declaration dropped." {file: "chrome://browser/skin/platform.css" line: 356}]
The thread 'StartupCache' (0xf64) has exited with code 0 (0x0).
MetroWidget::GetDPI
The thread 'Media Decode' (0xec0) has exited with code 0 (0x0).
[JavaScript Error: "TypeError: aURL.indexOf is not a function" {file: "chrome://browser/content/Util.js" line: 168}]
Attempting to initialize layermanager for a window that has no view!
Attempting to initialize layermanager for a window that has no view!
[JavaScript Warning: "Error in parsing value for 'width'.  Declaration dropped." {file: "chrome://browser/content/browser.xul" line: 0}]
[JavaScript Warning: "Error in parsing value for 'width'.  Declaration dropped." {file: "chrome://browser/content/browser.xul" line: 0}]
[JavaScript Warning: "Error in parsing value for 'width'.  Declaration dropped." {file: "chrome://browser/content/browser.xul" line: 0}]
[JavaScript Warning: "Error in parsing value for 'width'.  Declaration dropped." {file: "chrome://browser/content/browser.xul" line: 0}]
[JavaScript Warning: "Error in parsing value for 'width'.  Declaration dropped." {file: "chrome://browser/content/browser.xul" line: 0}]
[JavaScript Warning: "Error in parsing value for 'width'.  Declaration dropped." {file: "chrome://browser/content/browser.xul" line: 0}]
[JavaScript Warning: "Error in parsing value for 'width'.  Declaration dropped." {file: "chrome://browser/content/browser.xul" line: 0}]
[JavaScript Warning: "Error in parsing value for 'width'.  Declaration dropped." {file: "chrome://browser/content/browser.xul" line: 0}]
[JavaScript Warning: "Error in parsing value for 'width'.  Declaration dropped." {file: "chrome://browser/content/browser.xul" line: 0}]
[JavaScript Warning: "Error in parsing value for 'width'.  Declaration dropped." {file: "chrome://browser/content/browser.xul" line: 0}]
[JavaScript Warning: "Error in parsing value for 'width'.  Declaration dropped." {file: "chrome://browser/content/browser.xul" line: 0}]
[JavaScript Warning: "Error in parsing value for 'width'.  Declaration dropped." {file: "chrome://browser/content/browser.xul" line: 0}]
[JavaScript Warning: "Error in parsing value for 'width'.  Declaration dropped." {file: "chrome://browser/content/browser.xul" line: 0}]
[JavaScript Warning: "Error in parsing value for 'width'.  Declaration dropped." {file: "chrome://browser/content/browser.xul" line: 0}]
[JavaScript Warning: "Error in parsing value for 'width'.  Declaration dropped." {file: "chrome://browser/content/browser.xul" line: 0}]
[JavaScript Warning: "Error in parsing value for 'width'.  Declaration dropped." {file: "chrome://browser/content/browser.xul" line: 0}]
[JavaScript Warning: "Error in parsing value for 'width'.  Declaration dropped." {file: "chrome://browser/content/browser.xul" line: 0}]
[JavaScript Warning: "Error in parsing value for 'width'.  Declaration dropped." {file: "chrome://browser/content/browser.xul" line: 0}]
[JavaScript Warning: "Error in parsing value for 'width'.  Declaration dropped." {file: "chrome://browser/content/browser.xul" line: 0}]
[JavaScript Warning: "Error in parsing value for 'width'.  Declaration dropped." {file: "chrome://browser/content/browser.xul" line: 0}]
Attempting to initialize layermanager for a window that has no view!
Attempting to initialize layermanager for a window that has no view!
[JavaScript Warning: "Error in parsing value for 'width'.  Declaration dropped." {file: "chrome://browser/content/browser.xul" line: 0}]
The thread 0xa48 has exited with code 0 (0x0).
Attempting to initialize layermanager for a window that has no view!
Attempting to initialize layermanager for a window that has no view!
Attempting to initialize layermanager for a window that has no view!
Attempting to initialize layermanager for a window that has no view!
[JavaScript Warning: "Error in parsing value for 'width'.  Declaration dropped." {file: "chrome://browser/content/browser.xul" line: 0}]
[JavaScript Warning: "Error in parsing value for 'width'.  Declaration dropped." {file: "chrome://browser/content/browser.xul" line: 0}]
[JavaScript Warning: "Error in parsing value for 'width'.  Declaration dropped." {file: "chrome://browser/content/browser.xul" line: 0}]
Attempting to initialize layermanager for a window that has no view!
Attempting to initialize layermanager for a window that has no view!
Attempting to initialize layermanager for a window that has no view!
Attempting to initialize layermanager for a window that has no view!
Attempting to initialize layermanager for a window that has no view!
Attempting to initialize layermanager for a window that has no view!
Attempting to initialize layermanager for a window that has no view!
Attempting to initialize layermanager for a window that has no view!
Attempting to initialize layermanager for a window that has no view!
Attempting to initialize layermanager for a window that has no view!
Attempting to initialize layermanager for a window that has no view!
Attempting to initialize layermanager for a window that has no view!
[timing] start: 31ms
[timing] main: 765ms
[timing] startupCrashDetectionBegin: 1876ms
[timing] firstPaint: 3126ms
[timing] sessionRestored: 2594ms
[timing] createTopLevelWindow: 2235ms
[timing] firstLoadURI: 2891ms

which implies the page was opened, but there's no tab visible with the weather link. Seems like we might have some sort of a "hidden widget" problem here.
(Assignee)

Comment 5

5 years ago
seems to be fixed in a latest build. will re-open if it shows up again.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME

Comment 6

5 years ago
It's kind of working, but pretty spotty. Sometimes Firefox comes up as a blank light-grey window, sometimes the New Tab tab appears to the right of the opened page, sometimes to the left. Sometimes it's just the New Tab tab, and no opened page at all. There's probably still some work to do on this, but at least for now links from other apps will open up 2/3rds of the time...
(Assignee)

Comment 7

5 years ago
Testers are still seeing this.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Assignee)

Updated

5 years ago
Whiteboard: [metro-mvp][LOE:2] → [metro-mvp][LOE:2][metro-it2]
(Assignee)

Comment 8

5 years ago
This isn't going to make it2 (today) but it's up next on my list.
Whiteboard: [metro-mvp][LOE:2][metro-it2] → [metro-mvp][LOE:2][metro-it2][metro-it3]
(Assignee)

Comment 9

5 years ago
Created attachment 698968 [details] [diff] [review]
params patch

One issue I came across, we have a scope problem with a couple strings. When the utf8 string gets freed during tab creation, strange things can happen.
Attachment #698968 - Flags: review?(netzen)
Comment on attachment 698968 [details] [diff] [review]
params patch

Review of attachment 698968 [details] [diff] [review]:
-----------------------------------------------------------------

ouch nice fix.
Attachment #698968 - Flags: review?(netzen) → review+
(Assignee)

Comment 11

5 years ago
https://hg.mozilla.org/projects/elm/rev/4e50c1ef1a40
Whiteboard: [metro-mvp][LOE:2][metro-it2][metro-it3] → [metro-mvp][LOE:2][metro-it2][metro-it3][completed-elm]

Updated

5 years ago
Summary: External link clicks from metro apps occasionally don't open in the browser → Work - External link clicks from metro apps occasionally don't open in the browser
Whiteboard: [metro-mvp][LOE:2][metro-it2][metro-it3][completed-elm] → feature=work [completed-elm]
Resolving bugs in the Firefox for Metro product that are fixed on the elm branch.  Sorry for the bugspam.  Search your email for "bugspam-elm" if you want to find and delete all of these messages at once.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.