Closed Bug 797140 Opened 7 years ago Closed 7 years ago

[Settings] Missing options in Sound settings: Email, Calendar, Alerts, Camera Shutter

Categories

(Firefox OS Graveyard :: Gaia, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-basecamp:+)

VERIFIED FIXED
B2G C1 (to 19nov)
blocking-basecamp +

People

(Reporter: nhirata, Assigned: jj.evelyn)

References

Details

(Keywords: feature, Whiteboard: testrun 2)

Attachments

(2 files)

Attached image screenshot
## Environment :
Otoro phone, build 2012-10-02 us
Taken from default.xml in b2g-distro: 
* "platform_build" revision= 795261940c8b11fb7dddd7a8e9dd8561fdc4fb64
* "gaia" revision= 3e360f0875e519743e2ce3159cbb035d5e8334e1 
* "releases-mozilla-central" revision= 4914d55691e8f602f4275d614183a2cde6aa69db
* "gonk-misc" revision= 202d2c62443c098b125e5d9d7b42226d98230e44
  
## Repro :
1. go to settings -> sound
2. compare to spec : https://www.dropbox.com/sh/ygwfxk6chpshxdj/qVCvUXWOeG/Apps/Settings/R1_Personalization_v3.pdf pg 5

## Expected :
1. should see an email, calendar, alerts, and camera shutter

## Actual :
1. do not see email, calendar, alerts and camera shutter
Component: Gaia → Gaia::Calendar
Sorry not under the calendar component !
Component: Gaia::Calendar → Gaia
per discussion in https://github.com/mozilla-b2g/gaia/issues/3978#issuecomment-8960499, I implemented design #2, which removed "email" and "calendar" settings.
Evelyn is correct about removing email and calendar sound options, but we are still missing camera shutter and alerts. (Although I can live without alerts, I think camera shutter is important)
We currently don't have sounds for alert
Depends on: 796286
(sorry, submit the comment above unexpected)
We currently don't have sounds for alerts, I'll confirm this with Patryk for his plan.
Regard to camera shutter, we are waiting for bug 796286 fixed.
Assignee: nobody → ehung
Depends on: 807431
blocking-basecamp: --- → ?
Duplicate of this bug: 808923
blocking-basecamp: ? → +
Priority: -- → P1
Duplicate of this bug: 808929
Keywords: feature
We're marking this bug with the C1 milestone since it follows the criteria of "unfinished feature work" (see https://etherpad.mozilla.org/b2g-convergence-schedule).

If this work is not finished by Nov19, this bug will need an exception and will be called out at the upcoming Exec Review.
Target Milestone: --- → B2G C1 (to 19nov)
Blocks: 809768
Depends on: 809770
Blocks: 809770
No longer depends on: 809770
Attachment #679571 - Flags: review?(alive)
Attachment #679571 - Flags: review?(alive) → review+
I don't know the implementation detail of camera shutter and who owns it, but I could add notification function in system app based on this patch. Thanks Eve.
Please see blocks list to know follow-up work and owner.
If you will help on adding notification sound, then you should take bug 809770.
Thanks!
https://github.com/mozilla-b2g/gaia/pull/6276
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Unagi Build 20130104070203. Settings > Sound > Other sounds... no "Alerts" sounds included.
UCID: set-112
https://moztrap.mozilla.org/results/case/62832/
Whiteboard: testrun 2
Repros on Unagi device Build ID: 20130115070201   using the december 5th kernel 
v 1.0.0-Prerelease
You need to log in before you can comment on or make changes to this bug.