install of jre plugin fails with error 207

VERIFIED DUPLICATE of bug 80170

Status

VERIFIED DUPLICATE of bug 80170
18 years ago
8 years ago

People

(Reporter: oretruck, Assigned: xiaobin.lu)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
-------------------------------------------------------------------------------
file:///home/harold/downloads/jre.xpi  --  05/10/2001 01:29:57
-------------------------------------------------------------------------------


     Install **FAILED** with error -207
     Finished Installation  05/10/2001 01:29:58



I am running 0.9 for linux on freebsd

Comment 1

18 years ago
where are you downloading this package from ? Netscape.com site or from sun ?
I don't understand this bug report. I tried intalling jre from netscape.com site 
on linux and it worked for me.  Pls provide details..thx
Assignee: av → edburns
Component: Plug-ins → OJI

Comment 2

18 years ago
What version is your Java plugin?
(Reporter)

Comment 3

18 years ago
Install **FAILED** with error -207 - This is found in the install.log file

I downloaded the file from here:
ftp://ftp.netscape.com/pub/netscape6/english/6.0/unix/linux22/xpi/jre.xpi

If I open the file in Mozilla (file -> open) the installer is started, it asks
what package i want to install, i click ok, the download window then appears (I
assume as I have a local copy of the file this is copying the file to another
location such as /tmp.) I am now left with a single mozilla window attempting to
load a document and an entry in the install.log file.

I have manually unziped the file and copied it to mozilla/plugins and created
the symlink, this did not work.  I have also copied the plugin from the netscape
4.7 directory, this also did not work.

Comment 4

18 years ago
dude, you must be a victim of bug 78543.
(Reporter)

Comment 5

18 years ago
I don't believe that I am a victim of that bug, according to people on #mozilla
there is no debugging compiled into the release, so assuming i have understood
bug 78543 it isn't the problem.

Comment 6

18 years ago
:(
(Reporter)

Comment 7

18 years ago
It would seem that the install of the plugin fails very early on, the install
window closes after only a second or two.  This is nowhere near sufficent time
for it to copy the file from where it resides on the hard disk nor is it
sufficent time for the installer to unzip the archive.  What is the install
process?  What is the first thing the installer does? 

Comment 8

18 years ago
Harold, just give this a shot : 
try to install the jre form this link 
http://home.netscape.com/plugins/jvm.html

I am using a commercial netscape build on which this works fine. I will go thru 
the exact same steps on a mozilla build and let you know soon what happens 
exactly and what should happen.
Thanks for your patience !!

Comment 9

18 years ago
DOH !! ignore my last comment. It goes to the same page to fetch the 
installer..just realized. 

Comment 10

18 years ago
When I tried to install jre.xpi by clicking on the x86Linux link on the
Releases page at Mozilla.org, the file would get downloaded from netscape and
then would close.  The browser, however, just hung there. No error message.

I've downloaded the same file as Mr. Hotham, and opened it locally with the
0.9 browser with the same result. Again, no error message. The browser just
sits busy. Nothing gets added to /usr/lib/mozilla/chrome.

Platform: RH Linux 7.0.9 (Beta) 2.4.0-0.99.11 kernel
Mozilla 0.9.0 from linux7 RPMs: base/chat/devel/mail

I had the same results with a RH6.2/2.2.14 system.

And then I thought to run as 'root'. Installation worked on both platforms.
The JRE on runs my 6.2 system, however. But then, the path at netscape has
'linux22' in its path.

Maybe a warning should pop up when it needs to be root to install.

Hope this helps.

Comment 11

18 years ago
Typo: JRE only runs on my RH6.2 system.

Comment 12

18 years ago
Over to Xiaobin.
Assignee: edburns → xiaobin.lu
(Assignee)

Comment 13

18 years ago
Reopen 80170 if download fails.

*** This bug has been marked as a duplicate of 80170 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 14

17 years ago
SPAM: reassigning OJI bugs to new QA, pmac. (227 bugs)
QA Contact: shrir → pmac

Comment 15

17 years ago
Verified dup.
Status: RESOLVED → VERIFIED

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.