Strange artifacts on some sites

VERIFIED FIXED in Firefox 17

Status

()

Core
Graphics
--
major
VERIFIED FIXED
5 years ago
6 months ago

People

(Reporter: Virtual, Assigned: bas)

Tracking

({nightly-community, regression})

18 Branch
mozilla18
x86_64
Windows 7
nightly-community, regression
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(firefox17+ verified, firefox18+ verified)

Details

Attachments

(2 attachments)

probably triggered by:
Bug #778367 - [Azure] Minimize intermediate surface size used by push/popgroup
Blocks: 778367
Keywords: regression
google search is also affected as many other sites ;p

Comment 3

5 years ago
I can confirm on youtube.com.
Setting gfx.content.azure.enabled=false helps.

Steps to reproduce:
 1. Open http://www.youtube.com/watch?v=55s3T7VRQSc

Actual results:
  Missing images and texts to render.
  After mouse hover over empty area, then the missing items appears
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 4

5 years ago
Ugh, we really need a simplified testcase here :(

Comment 5

5 years ago
Created attachment 667482 [details]
reduced html


mouse hover over gray area
(Assignee)

Comment 6

5 years ago
I've found the bug, looks like I ruined a merge and have a potential bug, patch incoming.

Updated

5 years ago
tracking-firefox18: --- → ?
(Assignee)

Comment 7

5 years ago
Created attachment 667509 [details] [diff] [review]
Make sure we push only once and copy the full surface on PushGroupAndCopyBackground
Assignee: nobody → bas.schouten
Status: NEW → ASSIGNED
Attachment #667509 - Flags: review?(joe)

Updated

5 years ago
status-firefox18: --- → affected
tracking-firefox18: ? → +
Duplicate of this bug: 797421
Attachment #667509 - Flags: review?(joe) → review+
Duplicate of this bug: 797488
Bas, I filed Bug 795467 on 9/28 that may/may not be related, if you could take a look.
(Assignee)

Comment 11

5 years ago
(In reply to Brian Carpenter [:geeknik] from comment #10)
> Bas, I filed Bug 795467 on 9/28 that may/may not be related, if you could
> take a look.

I doubt it.

Comment 12

5 years ago
possible dupe: bug 797549
Summary: Strange artefacts on some sites → Strange artifacts on some sites
Please include a link to the inbound changeset when landing there. Also, is there any way to test this?
https://hg.mozilla.org/integration/mozilla-inbound/rev/cfa23be4f73c
Flags: in-testsuite?
https://hg.mozilla.org/mozilla-central/rev/cfa23be4f73c
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
status-firefox18: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla18

Updated

5 years ago
Depends on: 797888

Comment 15

5 years ago
Note, not just sites are affected. Some themes are also troubled by this, for example Nautipolis and Walnut. Just open a menu with short-cuts for example.
I hope that this is the fix to that also.

Updated

5 years ago
Duplicate of this bug: 797549

Comment 17

5 years ago
Ther are still some overlays artefacts on h5ai web gui
http://i.imgur.com/pEWNf.png
check those sites for example:
http://xhmikosr.1f0.de/mpc-hc/?folder=bXBjLWhj
http://larsjung.de/h5ai/sample/

My build: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20121004030525

Updated

5 years ago
Duplicate of this bug: 797950
Thank you! Artifacts are gone.
Marking as VERIFIED FIXED.

Using latest build from mozilla-inbound-win64 FYI
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:18.0) Gecko/18.0 Firefox/18.0
ID:20121004235827
Status: RESOLVED → VERIFIED
No longer depends on: 797888, 797950

Updated

5 years ago
Depends on: 798274
(Assignee)

Comment 20

5 years ago
Comment on attachment 667509 [details] [diff] [review]
Make sure we push only once and copy the full surface on PushGroupAndCopyBackground

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 778367
User impact if declined: Corrupt rendering
Testing completed (on m-c, etc.): Aurora testing
Risk to taking this patch (and alternatives if risky): Dee bug 778367
String or UUID changes made by this patch: None
Attachment #667509 - Flags: approval-mozilla-beta?
Comment on attachment 667509 [details] [diff] [review]
Make sure we push only once and copy the full surface on PushGroupAndCopyBackground

Please land this asap so it's in tomorrow's Beta.
Attachment #667509 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
status-firefox17: --- → affected
tracking-firefox17: --- → +

Updated

5 years ago
status-firefox17: affected → fixed
:Virtual, could you please check the latest Firefox 17 Beta is fixed as well?
status-firefox18: fixed → verified
Can't reproduce it on Mozilla Firefox 17 Beta 4 (Portable), so looks fixed :)

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0
buildID: 20121031065642
Source: Built from http://hg.mozilla.org/releases/mozilla-beta/rev/486335dcb4a2
Thanks :Virtual. If this starts happening again, please file a new bug and mark it as dependent on this one.
status-firefox17: fixed → verified
You need to log in before you can comment on or make changes to this bug.