"TypeError: Value not an object" when assigning null or undefined to an option

RESOLVED DUPLICATE of bug 797113

Status

()

RESOLVED DUPLICATE of bug 797113
6 years ago
6 years ago

People

(Reporter: glob, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 667494 [details]
testcase

it used to be possible to remove an option from a select by assigning it to null.  this now throws an error -- "TypeError: Value not an object".

  document.getElementById('some_select').options[0] = null;

this works in all other browsers, as well as firefox 15.
Assignee: general → nobody
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Component: JavaScript Engine → DOM: Core & HTML
OS: Mac OS X → All
Hardware: x86 → All
Resolution: --- → DUPLICATE
Duplicate of bug: 797113
You need to log in before you can comment on or make changes to this bug.