Closed Bug 797419 Opened 8 years ago Closed 8 years ago

Fix strict mode warnings in controller.js

Categories

(Core :: General, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla19

People

(Reporter: dzbarsky, Assigned: dzbarsky)

Details

Attachments

(1 file)

Attached patch PatchSplinter Review
No description provided.
Attachment #667529 - Flags: review?(mconnor)
Comment on attachment 667529 [details] [diff] [review]
Patch

moving this to mak, since he knows this code _much_ better than I do.
Attachment #667529 - Flags: review?(mconnor) → review?(mak77)
Comment on attachment 667529 [details] [diff] [review]
Patch

Review of attachment 667529 [details] [diff] [review]:
-----------------------------------------------------------------

just some styling nit in case you want to fix them (since the blame is going to change regardless), could be cleaned up better but let's avoid useless regressions :)

::: browser/components/places/content/controller.js
@@ +536,5 @@
> +
> +    var showRules = selectionAttr.split("|");
> +    var anyMatched = false;
> +    function metaDataNodeMatches(metaDataNode, rules) {
> +      for (var i=0; i < rules.length; i++) {

nit: while touching this, could you please fix the "i=0" to "i = 0"?

@@ +541,5 @@
> +        if (rules[i] in metaDataNode)
> +          return true;
> +      }
> +
> +      return false;

...and remove the newline above this return

@@ +543,5 @@
> +      }
> +
> +      return false;
> +    }
> +    for (var i = 0; i < aMetaData.length; ++i) {

... but add a newline before this for
Attachment #667529 - Flags: review?(mak77) → review+
https://hg.mozilla.org/mozilla-central/rev/3f78565df9f0
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla19
You need to log in before you can comment on or make changes to this bug.