Show breakdown of reviewer points on individual history page

VERIFIED FIXED in 2012-10-25

Status

P3
normal
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: krupa.mozbugs, Assigned: robhudson)

Tracking

2012-10-25
Points:
---

Details

(Whiteboard: [See comment 2])

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
The Editors want app review points to show up on Marketplace and add-on review points to show up on AMO. Currently they show up in both places.

We should fix that.
(Assignee)

Comment 1

6 years ago
On AMO I'm assuming you want all review points that aren't apps, right? And not just add-on review points.
(Reporter)

Comment 2

6 years ago
Amy is happy for admins to be able to see the breakdown of a particular editor's overall score

So, As an admin if I search for an editor I should be able to see 

Overall score:
Add-on review points:
App review points:
Persona review points:
Editor since:

As an Editor, they will only see their overall score (i think)
(Reporter)

Updated

6 years ago
Summary: Don't show app review points on AMO and vice-versa → Show the breakdown of reviewer points to admins
Whiteboard: [See comment 2]
(Assignee)

Comment 3

6 years ago
What I think would be nice is:

Have the user's reviewer scores be a page unto itself, something like /reviewers/user/robhudson. On that page show stuff like:
* total points
* current level
* number of points to the next level
* breakdown of points by add-on type (if the user also reviews add-ons, e.g.)
* point history

This page would be viewable by all other reviewers and admins.
Blocks: 739419
(Reporter)

Comment 4

6 years ago
(In reply to Rob Hudson [:robhudson] from comment #3)
> What I think would be nice is:
> 
> Have the user's reviewer scores be a page unto itself, something like
> /reviewers/user/robhudson. On that page show stuff like:
> * total points
> * current level
> * number of points to the next level
> * breakdown of points by add-on type (if the user also reviews add-ons, e.g.)
> * point history
> 
This should not block us from pushing the RI live. It is a great idea though.
> This page would be viewable by all other reviewers and admins.
(Assignee)

Comment 5

6 years ago
Created attachment 669197 [details]
Reviewer scores overview page
(Assignee)

Comment 6

6 years ago
Amy: Could you look at this and comment if it's enough? I snuck in a little bit of work on this Friday afternoon. It'd be nice to do more but this is all I was able to do.
(Assignee)

Updated

6 years ago
Target Milestone: 2012-10-04 → 2012-10-11
We already have https://addons.mozilla.org/editors/performance/ - it seems like that would be a good place to have the points too, rather than creating a new page.  

That page could have the detailed breakdown like in your overview screenshot (there is a dropdown at the top that lets you switch between users).
clarifying which bugs are for which things.  The other related bug is bug 739434
Summary: Show the breakdown of reviewer points to admins → Show breakdown of reviewer points on individual history page
Duplicate of this bug: 739436
This is half done so bumping into this milestone
Priority: -- → P3
Target Milestone: 2012-10-11 → 2012-10-18
(Assignee)

Comment 11

6 years ago
My plan:

* Put just the breakdown part in AMO with the other performance data, under the chart.
* Make a similar URL on mkt with the idea that we'd eventually add more reviewer performance data, but for now only the breakdown will be there.

The history can be viewed from the model admin by admins if need be. You can also add ?user=<user_id> to the URL once you're there to filter by user ID. Because of this I'm dropping this part.
(Assignee)

Comment 12

6 years ago
I didn't get to this at all this week. But the plan above still holds.
Target Milestone: 2012-10-18 → 2012-10-25
(Assignee)

Comment 13

6 years ago
On AMO:
https://addons-dev.allizom.org/en-US/editors/performance/

AMO also has a editor dropdown menu for admins that adds the ID to the URL above.

MKT:
https://marketplace-dev.allizom.org/reviewers/performance/

MKT does not have an editor dropdown menu for admins but if you append the username you can view other user's points. E.g.
https://marketplace-dev.allizom.org/reviewers/performance/robhudson

Feel free to file new bugs to expand on either of the above.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
The implementation is as per the spec in the earlier comments but my feeling is we'll want it broken down further than just Add-on/App as the majority of reviewers will only do one type.  @atsay, any preference?

Comment 15

6 years ago
Yes, we don't expect very much crossover between add-ons and apps reviewers. So it would be useful to have something like the Recent History section you mocked up here https://bug797521.bugzilla.mozilla.org/attachment.cgi?id=669197
(In reply to Amy Tsay [:amyt] from comment #15)
> Yes, we don't expect very much crossover between add-ons and apps reviewers.
> So it would be useful to have something like the Recent History section you
> mocked up here
> https://bug797521.bugzilla.mozilla.org/attachment.cgi?id=669197

Do reviewers need that level of history detail?  Maybe something in between more like the review performance, where it shows current month, year, etc? (Admins can get the full breakdown via a model in /admin btw.)

Comment 17

6 years ago
Sure, that sounds fine to me.

Comment 18

6 years ago
Verified as fixed in https://marketplace-dev.allizom.org/reviewers/performance/ on FF20 (Win 7)
Attaching postfix screenshot.
Closing bug.
Status: RESOLVED → VERIFIED

Comment 19

6 years ago
Created attachment 685592 [details]
postfix reviewer points
You need to log in before you can comment on or make changes to this bug.