Last Comment Bug 797524 - Thunderbird build is broken after Bug 795065 (error: no matching function for call to ‘nsITransfer::Init…)
: Thunderbird build is broken after Bug 795065 (error: no matching function for...
Status: RESOLVED FIXED
:
Product: MailNews Core
Classification: Components
Component: Backend (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Thunderbird 18.0
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks: 795065
  Show dependency treegraph
 
Reported: 2012-10-03 13:31 PDT by ojab
Modified: 2012-10-25 07:01 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
fixed


Attachments
bustage fix, add missing parameter to nsITransfer::Init() [check-in comment 7] (920 bytes, patch)
2012-10-04 05:51 PDT, Stefan Sitter
standard8: review+
Details | Diff | Review
Add missing parameters to saveURL (1.16 KB, patch)
2012-10-04 13:06 PDT, :Irving Reid (No longer working on Firefox)
standard8: review+
standard8: approval‑comm‑aurora+
Details | Diff | Review

Description ojab 2012-10-03 13:31:29 PDT
c++ -o nsMessenger.o -c -I../../../mozilla/dist/stl_wrappers -I../../../mozilla/dist/system_wrappers -include /sources/comm-central/mozilla/config/gcc_hidden.h -DMOZ_LDAP_XPCOM -DMOZ_GLUE_IN_PROGRAM -DMOZILLA_INTERNAL_API -D_IMPL_NS_COM -DEXPORT_XPT_API -DEXPORT_XPTC_API -D_IMPL_NS_GFX -D_IMPL_NS_WIDGET -DIMPL_XREAPI -DIMPL_NS_NET -DIMPL_THEBES  -DMOZ_THUNDERBIRD=1 -DOSTYPE=\"Linux3.6\" -DOSARCH=Linux -DHAVE_MOVEMAIL  -I/sources/comm-central/mailnews/base/src -I. -I../../../mozilla/dist/include -I../../../mozilla/dist/include/nsprpub  `/home/ojab/opt/mail/mozilla/dist/sdk/bin/nspr-config --prefix=/home/ojab/opt/mail/mozilla/dist --includedir=/home/ojab/opt/mail/mozilla/dist/include/nspr --cflags` -I/home/ojab/opt/mail/mozilla/dist/include/nss      -fPIC  -pedantic -Wall -Wpointer-arith -Woverloaded-virtual -Werror=return-type -Wtype-limits -Wempty-body -Wno-ctor-dtor-privacy -Wno-overlength-strings -Wno-invalid-offsetof -Wno-variadic-macros -Wcast-align -Wno-long-long -fno-exceptions -fno-strict-aliasing -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -std=gnu++0x -pthread -pipe  -DNDEBUG -DTRIMMED -g -Os -freorder-blocks  -fomit-frame-pointer   -DMOZILLA_CLIENT -include ../../../comm-config.h -MD -MF .deps/nsMessenger.pp /sources/comm-central/mailnews/base/src/nsMessenger.cpp
/sources/comm-central/mailnews/base/src/nsMessenger.cpp: In member function ‘nsresult nsSaveMsgListener::InitializeDownload(nsIRequest*, uint32_t)’:
/sources/comm-central/mailnews/base/src/nsMessenger.cpp:1726:57: error: no matching function for call to ‘nsITransfer::Init(nsCOMPtr<nsIURI>&, nsCOMPtr<nsIURI>&, const nsAFlatString&, nsCOMPtr<nsIMIMEInfo>&, PRTime&, NULL, nsSaveMsgListener* const)’
/sources/comm-central/mailnews/base/src/nsMessenger.cpp:1726:57: note: candidate is:
In file included from /sources/comm-central/mailnews/base/src/nsMessenger.cpp:102:0:
../../../mozilla/dist/include/nsITransfer.h:39:14: note: virtual nsresult nsITransfer::Init(nsIURI*, nsIURI*, const nsAString_internal&, nsIMIMEInfo*, PRTime, nsIFile*, nsICancelable*, bool)
../../../mozilla/dist/include/nsITransfer.h:39:14: note:   candidate expects 8 arguments, 7 provided
make[8]: *** [nsMessenger.o] Error 1
make[8]: Leaving directory `/home/ojab/opt/mail/mailnews/base/src'
make[7]: *** [src_libs] Error 2
Comment 1 Mark Banner (:standard8) 2012-10-03 23:49:23 PDT
The build bustage should be quite easy to fix - we just need to add an extra parameter to the call - which can be hard-coded as false as we don't support private browsing in Thunderbird.

Looking at the changes here:

http://hg.mozilla.org/mozilla-central/rev/eff426a003e1

We also need to port the addition of the parameter to saveURL (http://mxr.mozilla.org/comm-central/search?string=saveURL), most of which we should be able to get hints from the mozilla-central changeset.

SeaMonkey may also need changes for addDownload and the download manager.

I'm not working on this for at least a few hours, so anyone is welcome to take it.
Comment 2 Mark Banner (:standard8) 2012-10-03 23:49:50 PDT
(In reply to Mark Banner (:standard8) from comment #1)
> I'm not working on this for at least a few hours, so anyone is welcome to
> take it.

(So assign it to yourself or comment on the bug if you are)
Comment 3 Stefan Sitter 2012-10-04 05:51:31 PDT
Created attachment 667926 [details] [diff] [review]
bustage fix, add missing parameter to nsITransfer::Init() [check-in comment 7]

Patch allows me to continue building. 
Still needs someone to look at the other places mentioned in Comment 1.
Comment 4 Mark Banner (:standard8) 2012-10-04 05:53:37 PDT
Comment on attachment 667926 [details] [diff] [review]
bustage fix, add missing parameter to nsITransfer::Init() [check-in comment 7]

This is fine, but I'd prefer the saveURL to be fixed at the same time as this lands so that we don't miss it later.
Comment 5 Mark Banner (:standard8) 2012-10-04 05:54:43 PDT
(In reply to Mark Banner (:standard8) from comment #4)
> This is fine, but I'd prefer the saveURL to be fixed at the same time as
> this lands so that we don't miss it later.

That's at least the mail/ part.
Comment 6 Stefan Sitter 2012-10-04 06:25:14 PDT
Sure. I'll let you decide whether to check-in the patch now or together with the remaining fixes.
Comment 7 Philip Chee 2012-10-04 10:28:53 PDT
Pushed part 1:
http://hg.mozilla.org/comm-central/rev/3dc4ff7e8600
Comment 8 :Irving Reid (No longer working on Firefox) 2012-10-04 13:06:43 PDT
Created attachment 668138 [details] [diff] [review]
Add missing parameters to saveURL

This passes the message window XUL document as the private-browsing context, rather than the actual email message document. This shouldn't matter, since we don't do private browsing at all.
Comment 9 :Irving Reid (No longer working on Firefox) 2012-10-09 09:13:46 PDT
Oops, missed the Aurora uplift with this one...

https://hg.mozilla.org/comm-central/rev/0e346725f8e6
Comment 10 :Irving Reid (No longer working on Firefox) 2012-10-09 09:16:09 PDT
Comment on attachment 668138 [details] [diff] [review]
Add missing parameters to saveURL

[Approval Request Comment]
Regression caused by (bug #):  Bug 795065
User impact if declined: Save Link and Save Inline Image right-click actions don't work
Testing completed (on c-c, etc.): 
Risk to taking this patch (and alternatives if risky): Low
Comment 11 :Irving Reid (No longer working on Firefox) 2012-10-11 07:00:09 PDT
Pushed to aurora:

https://hg.mozilla.org/releases/comm-aurora/rev/1cdda6660ee7

Note You need to log in before you can comment on or make changes to this bug.