Mozilla Maintenance Service does not run

RESOLVED INVALID

Status

()

Toolkit
Application Update
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: st3fan, Unassigned)

Tracking

15 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
I installed 15.0.1 on a Windows 7 (64) machine and I see that the Mozilla Maintenance Service is not running. This might explain why my Firefox was never updated automatically in the past.

When I go to the Task Manager I see that the service is registered but it has status Stopped and is set to be started Manual.

I don't think that is correct?
It isn't implemented for x64 yet
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 715876
(Reporter)

Comment 2

6 years ago
I actually see now that I installed the 32 bit version of Firefox on a Windows 7/64 system. Does that matter?
(Reporter)

Comment 3

6 years ago
My build target is: i686-pc-mingw32
(In reply to Stefan Arentz [:st3fan] from comment #0)
> I installed 15.0.1 on a Windows 7 (64) machine and I see that the Mozilla
> Maintenance Service is not running. This might explain why my Firefox was
> never updated automatically in the past.
> 
> When I go to the Task Manager I see that the service is registered but it
> has status Stopped and is set to be started Manual.
> 
> I don't think that is correct?
That is correct. It only runs when it needs to apply the update.

(In reply to Stefan Arentz [:st3fan] from comment #2)
> I actually see now that I installed the 32 bit version of Firefox on a
> Windows 7/64 system. Does that matter?
It doesn't.

What is the exact problem you are seeing? For example, I am certain some people expect the service to download the update which it doesn't do for a variety of good reasons.
(Reporter)

Comment 5

6 years ago
The problem is that the silent updates don't seem to work for me on this machine. Earlier today I noticed that I was still on 14. Of course opening the About box triggered the download of 15.0.1.

I am not a Windows expert at all. I just assumed that the Maintenance Service should be running in the background to enable those updates.
The service just removes the UAC prompt. Did you see the UAC prompt?
Note: this is the reason I wanted different names for the projects so people weren't mislead by the name
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Based on the expectation in comment #5 and that the maintenance service intentionally doesn't download updates per comment #4 resolving invalid
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → INVALID
(In reply to Stefan Arentz [:st3fan] from comment #0)
> I installed 15.0.1 on a Windows 7 (64) machine and I see that the Mozilla
> Maintenance Service is not running. This might explain why my Firefox was
> never updated automatically in the past.
> 
> When I go to the Task Manager I see that the service is registered but it
> has status Stopped and is set to be started Manual.
> 
> I don't think that is correct?

This is normal, the service is an on demand service. It is only started for the duration of an update and then it is stopped again.  There will be a v16 update coming out next week.  Let's wait until October 10th and then report back if you are on v16, and if you got a UAC prompt to get that update.
(Reporter)

Comment 10

6 years ago
I'm back because Firefox is not updating.

At the beginning of this month, after comment 9, I removed all instances of Firefox from my Windows machine and did a clean install of 15.0.1.

Right now I still have 15.0.1 and never got an update notification or prompt. Even though I have used Firefox multiple times. I have also rebooted this machine a number of times between the 16.0.1 release and now.

What can I do to debug this? What do you need from me?
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
The service itself doesn't provide the prompts or download the update and as a matter of fact app update will fallback to using the method without the service. As this bug was filed it is invalid so changing it back to invalid. Please file a new bug report that describes what you are experiencing. Thanks
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.