Unable to enter more than one word in any text field using Swiftkey 3

RESOLVED FIXED

Status

()

defect
P1
major
RESOLVED FIXED
7 years ago
3 years ago

People

(Reporter: geeknik, Assigned: jchen)

Tracking

({regression})

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox16 unaffected, firefox17+ wontfix, firefox18- affected)

Details

()

Reporter

Description

7 years ago
I am unable to enter more than one word in any text field in Nightly for Android on my Nexus 7 with the Swiftkey 3 Tablet keyboard. For example, at www.google.com, when typing in search phrases, as soon as I hit the space bar, the word I just typed in is gone and the cursor is back at the beginning of the text field. If I go back to using the default Android keyboard, I don't see this issue. Version built from http://hg.mozilla.org/mozilla-central/rev/635fcc11d2b1.

Comment 1

7 years ago
I'm seeing this on my HTC One X too. Sadly on both stock 4.0.3 and 4.0.4.

Comment 2

7 years ago
CC'ing Aaron, as this is pretty critical.
Severity: normal → major
Priority: -- → P1

Comment 3

7 years ago
Will an aLogCat help at all?
Summary: Unable to enter more than one word in any text field using Swiftkey 3 Tablet → Unable to enter more than one word in any text field using Swiftkey 3

Comment 4

7 years ago
I'm experiencing the same problem on my Nexus 7, Android version 4.1.2, but in both Firefox Beta and Aurora (both updated to the latest versions). However, sometimes it does work, so I'm not quite sure what is going on.

I recorded a video of me typing in Firefox Aurora: http://www.flickr.com/photos/81272265@N04/8102152916/
I start out trying to type some words with SwiftKey and it doesn't work. Then I change to Android's preinstalled keyboard and now I can type. Then I change back to SwiftKey and it doesn't work anymore. Excuse me for the poor video resolution. The text area I used in the video can be found here: http://xmlgrid.net/xml2text.html (I just took something random to type in).

Comment 5

7 years ago
The problem appears to be in most cases that you can type as long as you don't use predictions, via clicking them individually or by letting Swiftkey spell check for you. Apologies Daniel, but can you reconfirm that the problem is happening on Firefox beta please?

Comment 6

7 years ago
I have recorded a new video where I'm trying to type some text in the same text area, but in Firefox Beta: http://www.youtube.com/watch?v=E4pe3TFC7zg (I also used a better camera, so you actually can see what I'm typing :P). As you can see, sometimes does the word I'm trying to autocomplete with the predictions disappear. But there is also a lot of other strange things going on, and it has actually never been this bad before. Perhaps I'm experiencing another bug.

Comment 7

7 years ago
You're seeing this bug somewhat. That said, you seem to have a few problems with Fennec on your device, it's running incredibly slow. I would recommend uninstalling and reinstalling. The fact that upon clicking a history item it takes you back to about:home first suggests there's a problem with your profile.

Comment 8

7 years ago
I reinstalled Firefox Beta and I'm still experiencing problems. The text field on Google's homepage works, but not the text area on the page I linked to earlier or the text area here. (I typed this message inside the Facebook app instead. :-P) On this page it's not as bad as on the XML site, only some words do disappear here. The text field on Google's homepage doesn't work in Aurora tho. 

The performance issue seems to be caused by my addons (LastPass and Adblock Plus) that I had enabled. When I disabled them Firefox became much faster after the startup. Maybe the LastPass addon downloads and decrypts all my passwords right after startup of Firefox, causing it to run slowly. And I think that I have about 300 passwords in my LastPass vault...  But this is probably not related to the typing bug, and I don't want to waste your time debugging my performance issues.
I have noticed as well that if I let SwiftKey auto-correct, the word never actually gets entered, and disappears. But if I tap the exact same word such that it doesn't "auto-correct", then the word is entered.
I swear that this is a regression. I can enter almost no text on Google or even Bugzilla due to it :(

Comment 11

7 years ago
How is today's Nightly build with bug 805162 fixed?
Aaron - can you determine when this regressed, and whether you're able to repro on FF17?
Keywords: qawanted
QA Contact: aaron.train

Comment 13

7 years ago
Thomas: I downloaded Nightly from the website some moments ago, installed it and typed some text in Google's text field and in a text area, and it worked correctly in both. The problem is still present in Aurora tho.
I am not able to reproduce this with either SwiftKey 3 Tablet or SwiftKey 3 for traditional phones on mozilla-17, mozilla-18 or mozilla-19 on my Samsung Galaxy Note II and Asus Nexus 7. Is this only an issue with some advanced reconfiguration in SwiftKey 3's options?

I went to Google.com/DuckDuckGo/Yahoo and was able to safely input an entire text in all fields fine. 

If this is working for others on mozilla-19, than it's clearly evident that Jim Chen's refactoring of thread-safe IME code has resolved the issue.

Assigning to Jim for investigation.
Assignee: nobody → nchen
Status: NEW → ASSIGNED
Keywords: qawanted

Comment 15

7 years ago
As someone that was effected by this bug, I'd say that bug 805162 seems to have fixed this issue.
Looks like we're not reproducing on Aurora/Beta - not tracking, please renominate if this does show up in 17 or 18.
That can't be certain, there's folks in here commenting in regard to Aurora and Beta ...

Comment 18

7 years ago
I am still experiencing the problem in both Beta and Aurora. Has the bugfix in Nightly that fixed this problem even been merged into those branches yet?
The fixed in bug 805162 have not been uplifted as they carry risk for those channels.

We need info from Jim to determine if anything can be done in the interim.
Flags: needinfo?(nchen)
(In reply to Aaron Train [:aaronmt] from comment #19)
> The fixed in bug 805162 have not been uplifted as they carry risk for those
> channels.
> 
> We need info from Jim to determine if anything can be done in the interim.

So I did not reproduce on Release or Beta, but I did reproduce on Aurora. My theory is that SwiftKey is blacklisting us on Release (and Beta maybe), since we always gave it trouble :)

But what that means is we don't necessarily have to have a fix for this for 17 and 18. Since they will be blacklisted once they reach Release/Beta.

Nevertheless, I think we should still consider uplifting Bug 805162 to benefit all the other keyboards that the bug fixes.
Flags: needinfo?(nchen)

Comment 21

7 years ago
Strange that I'm able to reproduce it in Beta. However, I'm using the tablet version of SwiftKey, and perhaps it doesn't have the blacklisting you are talking about (whatever that is).
(In reply to Daniel Jonsson from comment #21)
> Strange that I'm able to reproduce it in Beta. However, I'm using the tablet
> version of SwiftKey, and perhaps it doesn't have the blacklisting you are
> talking about (whatever that is).

The easiest way to check is to see if the text is underlined as you type. If it is underlined, then SwiftKey is NOT blacklisting us. For me, using SwiftKey Tablet Trial 3.0.4.343, I see underline using Aurora, but not Release or Beta.

Comment 23

7 years ago
(In reply to Jim Chen [:jchen :nchen] from comment #22)
> (In reply to Daniel Jonsson from comment #21)
> > Strange that I'm able to reproduce it in Beta. However, I'm using the tablet
> > version of SwiftKey, and perhaps it doesn't have the blacklisting you are
> > talking about (whatever that is).
> 
> The easiest way to check is to see if the text is underlined as you type. If
> it is underlined, then SwiftKey is NOT blacklisting us. For me, using
> SwiftKey Tablet Trial 3.0.4.343, I see underline using Aurora, but not
> Release or Beta.

Okey, it's not underlined in Beta for me. But what does it mean that they are blacklisting an app?

It seems like some sites' text areas work less well than others. For an example, the one on this site works horribly for me in Beta: http://xmlgrid.net/xml2text.html
While only a few words disappear in this one's: http://textarea.org/
(In reply to Daniel Jonsson from comment #23)
> Okey, it's not underlined in Beta for me. But what does it mean that they
> are blacklisting an app?
> 
> It seems like some sites' text areas work less well than others. For an
> example, the one on this site works horribly for me in Beta:
> http://xmlgrid.net/xml2text.html
> While only a few words disappear in this one's: http://textarea.org/

Thanks for letting us know Daniel - can you check if you see this same behavior with the  release version of Firefox as well?

Comment 25

7 years ago
(In reply to Alex Keybl [:akeybl] from comment #24)
> 
> Thanks for letting us know Daniel - can you check if you see this same
> behavior with the  release version of Firefox as well?

Downloaded and installed the release version, and I can't find any problems with SwiftKey in it. So Release and Nightly work for me, but not Beta and Aurora. This is a bit confusing. O:-)
on nightly, I still have problems with workflowy.com. it tends to delete every word I write, sometimes leaving one or two letters.
Re-testing this once again; SwiftKey Trial (3.0.4.343) and Aurora (11/08) Samsung Galaxy Nexus (Android 4.1.2) - only on Aurora is where I can reproduce this on Google.com (SwiftKey is underlining) merely typing "this is a test", after a space on 'this', it blanks out.

* Firefox 16 - I can't reproduce
* Firefox 17 - I can't reproduce
* Firefox 18 - I can reproduce (underlining)
* Firefox 19 w/IME rework patches - I can't reproduce
Thanks for re-testing Aaron. Let's test one last time when FF18 hits beta, and if it doesn't reproduce there, we'll untrack and wait for FF19 to fix this issue completely on Nightly/Aurora.
On Beta, I did just reproduce on the site that Daniel mentioned, http://xmlgrid.net/xml2text.html, but that site uses a contentEditable div. We do have known issues with contentEditable, and AFAIK there is no quick, easy and safe way to fix it right now. This bug is *not* reproducible on Beta for regular input fields.

Comment 30

7 years ago
Okey, I didn't know about that limitation. Jim, does the following site work for you in Beta? http://textarea.org/
It has a text area and it removes words when I try to use the spell checking suggestions. 

And http://xmlgrid.net/xml2text.html works for me in Nightly, so it seems like the problem with contentEditable divs are fixed then? 8-)
We'll follow to see what happens with 18.0b1 here.

Jim, any other investigations needed here at the moment?
(In reply to Aaron Train [:aaronmt] from comment #31)
> We'll follow to see what happens with 18.0b1 here.
> 
> Jim, any other investigations needed here at the moment?

Not at the moment. Thanks.
We'll untrack for FF18 based upon feedback from FF17.

Comment 34

7 years ago
I'm having problems with Swiftkey on FF18b on my Nexus S. I've noticed this especially when trying to use the search box on mobile.facebook.com.
(In reply to Alex Keybl [:akeybl] from comment #33)
> We'll untrack for FF18 based upon feedback from FF17.

This hasn't been called out as a major user pain point post-release. Therefore, no need to track for upcoming versions of Firefox.

Comment 36

7 years ago
Regression window : 
Bad build:19.09.2012
Good build:20.09.2012

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=80499f04e875&tochange=1e56d3016820
Fixed in Firefox 19 Beta, to be released in two weeks.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.