Cannot add addresses to address book by click on star or right-click add to addressbook

RESOLVED WORKSFORME

Status

Thunderbird
Address Book
RESOLVED WORKSFORME
6 years ago
3 years ago

People

(Reporter: Monika Eggers, Unassigned)

Tracking

15 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:15.0) Gecko/20100101 Firefox/15.0.1
Build ID: 20120907231657

Steps to reproduce:

(1) Click on star next to from or to or cc e-mail address in an e-mail
(2) Righ-click on such an e-mail address and select add to address book from context menu


Actual results:

Nothing: No pop-up to select the address book to add to and to edit the data related to this address. Also the e-mail address did not get added to the address book. The star did not change to the full icon.

The error console shows this error: 
Error: NS_ERROR_INVALID_POINTER: Component returned failure code: 0x80004003 (NS_ERROR_INVALID_POINTER) [nsIAbDirectory.addCard] Source file: chrome://messenger/content/msgHdrViewOverlay.js Line: 1494

The same happens when starting in safe mode (i.e. nothing happens and the error console shows the same error).


Expected results:

The pop-up for selecting the address book and entering data relating to the address should have come up (like the name etc.)

Comment 1

6 years ago
It works for me fine in TB18.
Monika:

In your address book, is your Personal Address Book working correctly? Are you able to add and remove contacts properly?

Does the message-header star not work properly for a particular name / email address, or for any name / email address?

-Mike
(Reporter)

Comment 3

5 years ago
It's the same for all names / e-mail addresses (not working).

With my Personal Address Book something was wrong recently: It seems to have disappeared. Only the collected addresses address book was there. When right-clicking and selecting add address to there was a drop-down menu with just the collected addresses address book in it and I could select it and then it was successful.

I recently created a new personal address book that I just called "Addressbuch" (Address Book). There I can manually add new cards by clicking the New Contact button. It seems to work completely fine. Those addresses I add there afterwards have a yellow / full star in mails.

Comment 4

3 years ago
Sounds like corrupted address book, not directly caused by a problem with the code which adds new addresses.
WFM per comment 3
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.