Using Download or Don't in WorkOffline menu hangs (regression)

VERIFIED FIXED

Status

--
critical
VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: laurel, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
This was working in may08 commercial trunk build
Haven't tried all platforms yet...

When using the File|Offline|Work Offline menu to go offline, clicking either the
Download or Don't Download button in the pop-up dialog causes a hang, must end task.
(Reporter)

Comment 1

18 years ago
I'm using 2001-05-09 commercial trunk build on win98.
Severity: normal → critical
Keywords: nsbeta1, regression
(Reporter)

Comment 2

18 years ago
Hmmm... I see that Putterman logged a similar hang in bug 79627, he states he
was using may07 build.  I get different results (not as many steps to hang) and
I could've sworn I was able to do this without hanging yesterday.  I'll let
mohan decide if it's the same (probably). Assigning to him since he has the
other bug.
Assignee: dianesun → mohanb
QA Contact: esther → gchan
(Assignee)

Comment 3

18 years ago
I'm not seeing this in either scenario. Do you have any folders configured for
offline use?
(Reporter)

Comment 4

18 years ago
Dammit! Now it's not happening (bienvenu mental voodoo?), doesn't matter if any
folders or groups marked for offline or not.  It happened several times
before... I don't know what's the deal.

Comment 5

18 years ago
I'm not seeing either dialog show up so I don't know if this got fixed by not
making any dialogs appear when going online/offline or if there's another problem.

Comment 6

18 years ago
This is in response to this bug and Scott's.

Using the 2001050804 on NT 4.0 both situations worked fine. I didn't
see a problem with those 2 bugs.

Using the 2001050904 (2001-05-09-10-trunk) on NT 4.0 both situations
worked fine again. I did not see either of those 2 bugs. Though
with May 9th build if you click the offline indicator icon, you
will not get the 'do you want to download your messages' or 'do you
want to send your unsent mesgs' prompt that you did in
the May 8th build.

You still get the prompts if you  choose File|Offline|Work Offline menu.
(Assignee)

Comment 7

18 years ago
this might not agree with the spec, but I think clicking on the icon should just
toggle the online/offline state, and not do any prompting, just like 4.x
behaved. If you want prompting, you should use the menu items. CC'ing Jen for
comments.

Comment 8

18 years ago
I don't see this bug but I definitely still see the one I reported.  If I use
the menus to Work offline I get prompted to Download.  I say don't download. 
Nothing bad happens.  I then use the menus to Work Online.  I choose Don't Send
and I hang.  I see this on 2001050904 on Win NT (which is a different machine
than the one I used to file the bug)
(Assignee)

Comment 9

18 years ago
I see what you saw, Scott, and I have a fix for that - it only happened if my
first account was not IMAP.

Comment 10

18 years ago
IMAP is my first account at work and at home. But, as long as you are able to
reproduce it, that's cool.

Comment 11

18 years ago
I was thinking the icon would following the prefs (for prompting) the user has 
specified in Offline global preferences.
http://www.mozilla.org/mailnews/specs/offline/images/PrefOff1.gif
(Assignee)

Comment 12

18 years ago
I think the menu item should follow those prefs, but bonking the icon should do
the minimum required to put you in offline state - again, this is what 4.x did.
If bonking the icon prompted me everytime, I would never set the pref to ask me.
(Assignee)

Comment 13

18 years ago
The other detail is that we can't make the offline icon work that way in the non
mail/news windows, like the browser window, history window, etc. I think it
would be better to make the icon work consistently across all the windows.
(Granted, they have an offline menu in the browser window, but all windows have
the icon).
(Assignee)

Comment 14

18 years ago
taking
Assignee: mohanb → bienvenu
(Assignee)

Comment 15

18 years ago
fixed, I think (wasn't a regression).
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Keywords: regression
Resolution: --- → FIXED

Comment 16

18 years ago
>bonking the icon should do the minimum required to put you in offline state 

I don't feel strongly either way, so this is ok by me if you prefer

Comment 17

18 years ago
Verified on commerical branch builds
2001-06-05-11-0.9.1/ -windows
2001-06-05-04-0.9.1/ -linux
2001-06-05-03-0.9.1/ -mac

Using an imap account: Going offline and clicking the 
"download" or "don't download" button does not result in a hang.

Also tested with my Webmail account as my 'first account' and
did not see a problem either.

Also noting that when 'bonking' the online/offline indicator, the
user is prompted if they want to download their messages or not.
Not sure in David/Jennifer's discussion which way they wanted
the behavior when bonking the icon.

Since the fix (5/10) was fixed way before we started branching (6/1),
I am assuming this fix is reflected in the trunk builds and there
is no need to test the trunk.

Marking as verified.

Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.