At startup Thunderbird hang for minutes with lots of I/O on disk

RESOLVED WORKSFORME

Status

Thunderbird
General
--
major
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: natim, Unassigned)

Tracking

({perf})

15 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/536.11 (KHTML, like Gecko) Ubuntu/12.04 Chromium/20.0.1132.47 Chrome/20.0.1132.47 Safari/536.11

Steps to reproduce:

I stopped to use my thunderbird for somes days and when I opened it agains it loads my IMAP accounts.


Actual results:

Now each time I launch Thunderbird it takes minutes with lots of I/O on disk.

http://askubuntu.com/questions/195618/how-can-i-make-thunderbird-faster


Expected results:

Even after the first run if I close Thunderbird and restart it it restart making lots of disk I/O.

What can I do to give you useful information so we can make this never happens again?
can you disbale global indexing and see if that fixes the issue ?

Comment 2

6 years ago
If global indexing is impacting your startup then I would expect that is more symptom than cause - and that you also have lots messages redownloading - is that what you are saying in comment 0 "it agains it loads my IMAP accounts"? Is it redownloading entire folders - see the activity manager?  And, is this only your gmail account?

please also comment on whether you see high memory usage, eg >400MB?

Lastly, what version of thunderbird last worked properly for you?
Severity: normal → major
Keywords: perf
(Reporter)

Comment 3

6 years ago
Thank you for your fast review. How can I disable global indexing ?
How can I launch the activity manager to see message redownloading ?

For the last version that worked I have no idea really.

Comment 4

6 years ago
Tools | activity manager - and you will see this download activity even if you disable global index at tools | options | advanced | general | uncheck enable global search
(Reporter)

Comment 5

6 years ago
Ok so, Activity Manager : Indexing 1600 messages, Download 1300 messages in Inbox

Comment 6

6 years ago
Remy, soundsl like your folder is reloading. Did this stop in version 16?
And if not, then perhaps you are seeing bug 806760
Flags: needinfo?(hubscher.remy)
(Reporter)

Comment 7

6 years ago
I don't have this problem anymore.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Flags: needinfo?(hubscher.remy)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.