Closed Bug 797867 Opened 8 years ago Closed 8 years ago

can't enter space in browser URL bar

Categories

(Firefox OS Graveyard :: Gaia::Browser, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-basecamp:+)

VERIFIED FIXED
blocking-basecamp +

People

(Reporter: vlad, Assigned: benfrancis)

References

Details

When in the URL bar of the b2g browser, the on-screen keyboard has no space, and it doesn't show up on any secondary screens -- this makes it rather difficult to search for things using the search shortcuts listed in the pseudo-awesomebar.
Depends on: 796544
Assignee: nobody → ben
I think the conclusion in https://github.com/mozilla-b2g/gaia/issues/3566 is to change the input type from url to text and use the standard text keyboard for the awesomebar.

If we did this right now it would cause the first letter to be capitalised, which is not ideal. inputMode support is coming for the keyboard in bug 796544 so that the browser can tell the keyboard not to capitalise the first letter, then it will make sense to make this change.
blocking-basecamp: ? → +
Priority: -- → P1
I've got a patch ready in #796544 that partially implements inputmode. Enough to turn off auto capitalization, and enable a fix for this issue.

But I can't test it and land it until #800817 is resolved.
No longer depends on: 796544
https://github.com/mozilla-b2g/gaia/pull/5955
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Duplicate of this bug: 805657
Verified fix on 10/26 daily otoro build.  spacebar lives!
BuildID=20121026074010
Status: RESOLVED → VERIFIED
Duplicate of this bug: 806962
Duplicate of this bug: 807077
Ben, I still believe that we may get more value out of modifying the URL input keyboard like we discussed yesterday.  

Josh, additional thoughts here?
(In reply to Chris Lee [:clee] from comment #8)
> Ben, I still believe that we may get more value out of modifying the URL
> input keyboard like we discussed yesterday.  

Could you give more information? Adding a space key in the url keyboard isn't a good idea because except the awesome bar, no one needs that.
You need to log in before you can comment on or make changes to this bug.