error: implicit conversion of NULL constant to 'NSWorkspaceLaunchOptions' (aka 'unsigned long') [-Werror,-Wnull-conversion]

RESOLVED DUPLICATE of bug 797834

Status

()

Core
Widget: Cocoa
RESOLVED DUPLICATE of bug 797834
6 years ago
6 years ago

People

(Reporter: rnewman, Unassigned)

Tracking

Trunk
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
changeset:   109231:4cb8f88213f5
parent:      109215:0a095af171f4
parent:      109230:7129a1d713f4
user:        Panos Astithas <past@mozilla.com>
date:        Thu Oct 04 09:54:25 2012 +0300
summary:     Merge m-c to fx-team




/Users/rnewman/moz/hg/services-central/widget/cocoa/nsMacWebAppUtils.mm:49:34: error: implicit conversion of NULL constant to 'NSWorkspaceLaunchOptions' (aka 'unsigned long') [-Werror,-Wnull-conversion]
                        options: nil
                                 ^~~
/System/Library/Frameworks/CoreServices.framework/Headers/../Frameworks/CarbonCore.framework/Headers/MacTypes.h:69:17: note: expanded from macro 'nil'
    #define nil NULL
                ^~~~
1 error generated.

In the directory  /Users/rnewman/moz/hg/services-central/obj-ff-dbg/widget/cocoa
The following command failed to execute properly:
/usr/local/bin/ccache /usr/local/Cellar/llvm/3.1/bin/clang++ -o nsMacWebAppUtils.o -c -fvisibility=hidden -DXPCOM_TRANSLATE_NSGM_ENTRY_POINT=1 -DMOZILLA_INTERNAL_API -D_IMPL_NS_COM -DEXPORT_XPT_API -DEXPORT_XPTC_API -D_IMPL_NS_GFX -D_IMPL_NS_WIDGET -DIMPL_XREAPI -DIMPL_NS_NET -DIMPL_THEBES -DSTATIC_EXPORTABLE_JS_API -DNO_X11 -I/Users/rnewman/moz/hg/services-central/widget/cocoa/../xpwidgets -I/Users/rnewman/moz/hg/services-central/widget/cocoa/../shared -I/Users/rnewman/moz/hg/services-central/widget/cocoa -I. -I../../dist/include -I/Users/rnewman/moz/hg/services-central/obj-ff-dbg/dist/include/nspr -I/Users/rnewman/moz/hg/services-central/obj-ff-dbg/dist/include/nss -fPIC -Qunused-arguments -Qunused-arguments -Wall -Wpointer-arith -Woverloaded-virtual -Werror=return-type -Wtype-limits -Wempty-body -Werror=conversion-null -Wno-ctor-dtor-privacy -Wno-overlength-strings -Wno-invalid-offsetof -Wno-variadic-macros -Wno-c++0x-extensions -Wno-extended-offsetof -Wno-unknown-warning-option -Wno-return-type-c-linkage -Wno-mismatched-tags -fno-exceptions -fno-strict-aliasing -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -std=gnu++0x -pthread -DNO_X11 -pipe -DDEBUG -D_DEBUG -DTRACING -g -O2 -fno-omit-frame-pointer -Qunused-arguments -DMOZILLA_CLIENT -include ../../mozilla-config.h -MD -MF .deps/nsMacWebAppUtils.o.pp -fobjc-exceptions /Users/rnewman/moz/hg/services-central/widget/cocoa/nsMacWebAppUtils.mm
make[6]: *** [nsMacWebAppUtils.o] Error 1
make[6]: *** Waiting for unfinished jobs....
In file included from /Users/rnewman/moz/hg/services-central/widget/cocoa/GfxInfo.mm:11:
In file included from /Users/rnewman/moz/hg/services-central/widget/cocoa/GfxInfo.h:11:
In file included from /Users/rnewman/moz/hg/services-central/widget/cocoa/../xpwidgets/GfxInfoBase.h:15:
/Users/rnewman/moz/hg/services-central/widget/cocoa/../xpwidgets/GfxDriverInfo.h:144:13: warning: unused function 'SplitDriverVersion' [-Wunused-function]
static bool SplitDriverVersion(const char *aSource, char *aAStr, char *aBStr, char *aCStr, char *aDStr)
            ^
/Users/rnewman/moz/hg/services-central/widget/cocoa/../xpwidgets/GfxDriverInfo.h:187:13: warning: unused function 'PadDriverDecimal' [-Wunused-function]
static void PadDriverDecimal(char *aString)
            ^
2 warnings generated.
make[5]: *** [libs] Error 2
make[4]: *** [libs_tier_platform] Error 2
make[3]: *** [tier_platform] Error 2
make[2]: *** [default] Error 2
make[1]: *** [realbuild] Error 2
make: *** [build] Error 2
(Reporter)

Comment 1

6 years ago
This is after a clobber build.

Trying again now with 84 more recent changesets.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 797834
You need to log in before you can comment on or make changes to this bug.