Research: What domain do we want for live examples?

RESOLVED FIXED

Status

developer.mozilla.org
Editing
RESOLVED FIXED
6 years ago
2 years ago

People

(Reporter: openjck, Unassigned)

Tracking

Details

(Reporter)

Description

6 years ago
This is a continuation of bug 797925, marked as private so that our decision is not available to domain squatters.
(Reporter)

Updated

6 years ago
Duplicate of this bug: 797925
(Reporter)

Comment 2

6 years ago
Moving the discussion over here to prevent indexing. I can talk to IT about mozillademos.org. Will we still need it if we go with Louis-Remi's approach?
(In reply to John Karahalis [:openjck] from comment #2)
> Moving the discussion over here to prevent indexing. I can talk to IT about
> mozillademos.org. Will we still need it if we go with Louis-Remi's approach?

As I said in email, that was a really cool tech demo but I don't think we can use it directly. We still need an alternate domain name for live samples.
FWIW, I think mozillademos.org itself already points at a server.

If it makes things easier for IT, we might try something like using mdn.mozillademos.org and make that an alternate host for the entire site. Then, only serve up code samples and demo studio files (bug 664724) from there. 

jsocol mentioned building some middleware that would cause the site to refuse to serve up anything *but* samples from that domain. Not a blocker, but would be nice to have
Getting very close to needing this. Can we just file an IT bug to configure mdn.mozillademos.org as an alternate domain for developer.mozilla.org? Objections? Alternates?

(cc'ing jakem for opinions before opening an IT bug)
Just thought of a strike against mdn.mozillademos.org: Whatever domain we use, we need an SSL cert for it. I don't think we have one that covers that subdomain.
I bet we have ssl certs for mozilla.net domains?
(In reply to Luke Crouch [:groovecoder] from comment #7)
> I bet we have ssl certs for mozilla.net domains?

I'm sure we have SSL certs for lots of domains - just not for the particular one I mentioned, mdn.mozillademos.org. It depends on whether or not we have a wildcard cert, I think

Comment 9

6 years ago
Wildcards are generally not allowed anymore, apart from specific / special circumstances... so we'll almost certainly be buying a cert regardless. That's okay, there are good reasons for having a separate domain here so there's no problem with respect to cost... and acquisition time is generally same-day.

This sounds like it would tie in nicely with bug 664724. I'll see if we can poke that along a bit, in preparation of an IT bug for this.
Yeah, what would be awesome is if we could just point another domain (eg. mdn.mozillademos.org) at MDN, and maybe throw in some Apache config (ie. mod_rewrite?) that responds with 404 for anything except for Demo Studio assets or wiki URLs with $samples/{id}.

And for bonus points, do the inverse on developer.mozilla.org. Also, a robots.txt on the new domain that disallows all indexing.
(Reporter)

Comment 11

6 years ago
Opened bug 801041. Ended up mostly quoting Les since this is a little over my head, but it seems like Jake understands what we need.
Blocks: 722098
Depends on: 801041
We have a domain working, now: mdn.mozillademos.org
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
For bugs that are resolved, we remove the security flag. These haven't had their flag removed, so I'm removing it now.
Group: websites-security
You need to log in before you can comment on or make changes to this bug.